Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2020
    Location
    Maryland
    Posts
    1

    2020 RXPX Tune loads but still doesn't go past 70mph or 7800RPM's BAD ECU?

    I have a 2020 RXPX currently with about 30 hours on it.

    HISTORY:

    At the 10 hour service I had my local performance shop pair my key and my wife's key (GTI 170) together so they both operate each others ski.

    Stock Ski: (Other then keys same)

    One day at end of the day my check engine light came on and went off. Since It went off I didn't think much about it.

    Next few days I installed Riva Exhaust eliminator pipe and oil catch can. Went to load Map Tuner X 8500 Tune (Stock Tune Removing limiters) and said the tune was successful. Took it out and no difference! Tried to load 2 other Tunes and still nothing.

    Took it to my local shop and told them about the check engine code which is U0100 and I had them install stage 2 tune. Tune loaded successful. They said the U0100 was bad communication with ecu? (Something I did of course)

    Next day took it out and when it started the check engine beeped and light came on and went off after 45 seconds or so. Still took it out and still no difference.

    Spoke w/my local shop and he says the tune loaded correctly and it shows that tune in there and suggest I take it to dealer and have them check the check engine code?! (Possibly bad ECU)

    What's been noticed / different:
    Since I've had the keys paired it does not make any beep noise when there started and with the key's connected the gauge cluster stays on and does not time out. (IDK If this has anything to do with the tune just trying to give as much info as possible)

    I've emailed Jesus at Riva and he just confirms somethings wrong just hard to diagnose over email. Which I totally understand so my big question is has this happen to anyone or any other ideas? Dealership is 3 weeks out so not looking forward to dropping it off there!

  2. #2
    Tucka's Avatar
    Join Date
    Jun 2012
    Location
    mount warrigal NSW Australia
    Posts
    115
    +1
    15
    I bought the maptuner x and licence tune but didn't get any increase in speed and RPM, RPM won't go past 8080 , even when I downloaded the 8350 and bone stock 8500 tune. Vtech Dealer says I need a after market impeller. Not sure if that is true though.

  3. #3
    Davrac's Avatar
    Join Date
    Jan 2015
    Location
    Dubbo Australia
    Posts
    788
    +1
    130
    What ski is that on Tucka? Have you installed an air intake upgrade?


  4. #4
    Jarek's Avatar
    Join Date
    Oct 2019
    Location
    Cork, Ireland
    Posts
    30
    I would also check slip moment on sc. When sc fails (basically no boost) engine revs up to 6700-6800 max. And You can feel loose of power. It might be on partial boost. So as it was said check boost for sure.
    With the instruments which not goes off in my 2012 rxp260 same problem and I had to replace dess post. But it was older key. The new rf keys dess post might work differently.
    I would also checked all connectors. If there is no green of death. Perhaps some of the water gets in. Same with fusebox.

    good luck with that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2020 GTX won't rev past 6800 RPM
    By Northstar in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-13-2020, 04:04 PM
  2. SOLD 2012 RXPX 260 ECU W/ Tune.
    By Water4fire in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-06-2018, 09:56 AM
  3. FS 2012 RXPX ECU With Vtech tune.
    By Water4fire in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 11-02-2017, 08:42 PM
  4. 2015 RXPX-260 ecu tune. Stock for now
    By Buick87gn in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-16-2017, 08:09 PM
  5. RXT-X hitting 70mph tune and intercooler
    By redbarron in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-08-2016, 05:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •