Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2020
    Location
    New Hampshire
    Posts
    14
    +1
    3

    Looking for Expert 2-Stroke Polaris PWC Service in New Hampshire / Massachusetts Area

    I have a 99 1050 SLTX that is refusing to catch after a complete top end rebuild. 120psi Compression, Pressure Tested, Spark, Fuel, Reeds Ok, new bendix, flywheel correctly on its key. It's all there but it refuses to even attempt to catch.

    All it will do is occasionally ignite the fuel in the exhaust resulting an a backfire in the exhaust. I just want someone who really knows these things to have a look at it and see if something is off and get it running.


  2. #2

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    198
    +1
    12
    That is usually a timing issue . . . check you CPS, TPS, and your EMM. You can ohm out your CPS and TPS to ensure they show the correct values as listed in the service manuals.

    Manuals are available via the Polaris PWC Info Link in my signature.

    If they are OK, then I would say its the EMM. I would only trust my EMM to Lakeside Tech . . . link in my signature

  3. #3
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,819
    +1
    1,576
    Quote Originally Posted by bfarnam View Post
    That is usually a timing issue . . . check you CPS, TPS, and your EMM. You can ohm out your CPS and TPS to ensure they show the correct values as listed in the service manuals.

    Manuals are available via the Polaris PWC Info Link in my signature.

    If they are OK, then I would say its the EMM. I would only trust my EMM to Lakeside Tech . . . link in my signature
    This is not a fuel injected machine. It has carbs and a CDI ignition

  4. #4
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,819
    +1
    1,576
    Check your battery voltage while cranking. Anything less than 10.6 volts will give no spark

  5. #5

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    198
    +1
    12
    Quote Originally Posted by Mr. GP1800 View Post
    This is not a fuel injected machine. It has carbs and a CDI ignition

    Hahahaha I opened up several threads at once and got confused with the guy with the 03 Virage i . . . LOL

    Still a timing issue though . . . I don't really know enough about the carbs to help anymore . . .

  6. #6

    Join Date
    Aug 2020
    Location
    New Hampshire
    Posts
    14
    +1
    3
    I was able to figure out that the previous owner had replaced the coil(s) pack and re-inserted the wires in the wrong order. Fixed that and cleaned up the contacts in the box and it fired first shot.

    I had originally though this engine used wasted spark and not uniquely firing coils.


  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    9,139
    +1
    2,220
    Quote Originally Posted by kingofl337 View Post
    I was able to figure out that the previous owner had replaced the coil(s) pack and re-inserted the wires in the wrong order. Fixed that and cleaned up the contacts in the box and it fired first shot.

    I had originally though this engine used wasted spark and not uniquely firing coils.
    Pro Tip:

    When you are talking about your skis issues, its always good to mention if it's new to you and if its not, how it was running before the issue appeared.

    You got a good clue where to go, so we're all glad it worked out for you before you popped a resonator.

    Don't push a backfiring polaris engine, nothing good come of it, and you'll create all sorts of side problem

    Timing issues need to be solved, and not by a crank a thon.

    Bet you felt pretty slick when you hit the button and the engine was running. I always do.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris PWC Service
    By skijenn in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-04-2015, 07:12 PM
  2. Help! I need service for Polaris Watercraft in Chicagoland area!
    By Plrs X45 in forum Polaris Open Discussion
    Replies: 35
    Last Post: 07-05-2014, 09:02 PM
  3. Massachusetts PWC owners
    By dolson in forum Open Discussion
    Replies: 0
    Last Post: 12-01-2013, 08:27 PM
  4. Polaris service locations in New Hampshire?
    By Pmaggiotto in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-12-2013, 08:25 AM
  5. Polaris Service in Chicagoland Area?
    By abodner in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-20-2010, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •