Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32
  1. #1

    2020 RXP Performance Issue

    Right now my 2020 RXP 300 is no quicker than my stock 2012 RXT 260 AS (Suspension model) and I'm really pulling my hair out over this issue and I'm hoping some of the experts on this forum could weigh in. I recently picked up a lightly modded Sea Doo RXP 300 with about 25 hours on it in essentially new condition. The only mods are a Riva catch can and SCOM (also has new oem impeller and wear ring).

    While the ski is quick it's not as fast as it should be. The best 0-60 I get is in the mid 5 seconds (identical to the RXT 260) while everyone else is in the low 4s or even high 3s. Also, it's only maxing out at 71 mph and has trouble reving to 7700/7800 rpm when max hp is achieved at 8k.

    First thing I checked was the oil and found it was over a quart overfilled. After getting the oil filled correctly still no difference. Next I pulled the intercooler thinking the excess oil got in there but it is completely clean, like new. Next I replaced the plugs and just tested it this evening and it's still pulling 0-60 in 5.5 seconds.

    What else should I be looking at? It's essentially a brand new ski so I don't understand why it's not performing at 100%.

    Thanks in advance!

    UPDATE:
    My PX 300 seems to be fixed and running better than ever. I went through and tightened all the charger/ic hoses and moved the catch can to a lower mounting position. The previous owner had fabricated his own mounting bracket since the RIVA one did fit. It put the catch can at a higher elevation making any oil leaving the engine having to travel uphill. I was able to get the RIVA bracket to work by using some spacers.

    I'm not sure what exactly fixed it but now I'm running 0-60 in the low 4s high 3s, revving past 8000 rpms and am seeing 77/78 mph on the dash (75 GPS). Fuel economy also seems to have improved a bit which is kind of an oxymoron with this thirsty beast. If I learned anything from this experience is that you should never discount the simple fixes, it could be a loose hose clamp or a partially fouled plug keeping you from running 100%.

    Thanks again to everyone who contributed to this thread.
    Last edited by pwradder; 09-23-2020 at 11:24 PM. Reason: update


  2. #2
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,479
    +1
    356
    25 hrs. and the ski has a new prop and wear ring? What happened there?

    That’s where I’d be looking first...

  3. #3
    Quote Originally Posted by pwradder View Post
    Also, it's only maxing out at 71 mph and has trouble reving to 7700/7800 rpm when max hp is achieved at 8k.
    this is where hard driving on a cold engine ends

  4. #4
    The guy I bought it from sucked up a rock, so he put a fresh prop and wear ring on it. But I don't think it's a jet pump issue since I don't have any cavitation.

  5. #5
    Quote Originally Posted by Kazik_R52 View Post
    this is where hard driving on a cold engine ends
    candoo or buds make sure your throttle body is opening 100%. Fly by wire may not be giving u full throttle. Tas may be out od adjustment
    Last edited by Juicybusa; 08-30-2020 at 11:09 AM. Reason: Additional info

  6. #6
    Quote Originally Posted by Juicybusa View Post
    candoo or buds make sure your throttle body is opening 100%. Fly by wire may not be giving u full throttle
    Tas may be out of adjustment

  7. #7
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,479
    +1
    356
    Quote Originally Posted by pwradder View Post
    The guy I bought it from sucked up a rock, so he put a fresh prop and wear ring on it. But I don't think it's a jet pump issue since I don't have any cavitation.
    Just saying in my experience, it's usually the stuff people mess with that winds up being the problem. I don't have any idea of the previous owner's skill set with watercraft or the surrounding circumstances, so...

    I'd be wondering where he got the new "oem" prop from, concerned that it was the correct prop for the ski, correct installation, etc...

    No cavitation is a good sign though...

  8. #8
    Quote Originally Posted by Vman View Post
    Just saying in my experience, it's usually the stuff people mess with that winds up being the problem. I don't have any idea of the previous owner's skill set with watercraft or the surrounding circumstances, so...

    I'd be wondering where he got the new "oem" prop from, concerned that it was the correct prop for the ski, correct installation, etc...

    No cavitation is a good sign though...
    Yeah, I've definitely seen that too...in this case, a dealer did all the work/sources the parts. I'll still look into though, thanks.

  9. #9
    Thanks for this...do you know how I would check to see if the tas is out of adjustment?

  10. #10
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    806
    +1
    82
    Maybe the new prop is to steep.
    That could be your explanation for slower acceleration.

    Eventually you reach either the GPS speed, RPM or torque limiter and the ECU pulls back a little.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2020 GTI-SE 130 Performance
    By tbarcia in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-19-2020, 01:29 PM
  2. 2020 RXT X 300 Intercooler issue
    By tchies in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-23-2020, 08:36 PM
  3. Issue With Catch Cans on 2020 1630s
    By jeff24680 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-02-2020, 09:55 PM
  4. 2020 FX SVHO v 2020 GP1800R Performance
    By Lochrider in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 06-02-2020, 04:31 PM
  5. Video: 2020 Sea-Doo GTX RXT-X 300 vs. 2020 RXP-X 300 Comparison
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 05-06-2020, 12:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •