Results 1 to 4 of 4
  1. #1

    Pump cone deteriorating. Anyone seen this before?

    I noticed an interesting situation with my ski and after searching on here I couldnít find any similar posts so I figured it might be some good conversation.

    ski: 2017 GP1800, stage 1 plus with a 13/18 solas. Itís gone 81.0mph(gps) at 8400rpms in less than optimal weather conditions(90ish air temp, 80ish water temp, high humidity) with a little less than a half tank and 80.5mph in slightly better weather(10 less degrees air, same water temps, much lower humidity) with a full tank but it was on the limiter. Note: the ski cavitates quite a bit on a hard take off from a stand still, hits the limiter 4-5 times and then pulls hard. Winter plans include pulling the pump and grate and ensuring the instal is done correctly and everything is nice and sealed up.

    this is what the pump cone looks like

    everything else looks fine from the outside looking in with an inspection mirror(impeller looks good, vanes all look fine, etc)

    thoughts on the cause of this? I picked up the ski used and it was like this when I bought it.

    I have a new factory cone on order and a lucky 13 cone on order as well. Once they come in Iíll report back with results with the new stock one and the lucky 13 in its various combinations (I will NOT be repitching the impeller or messing with the nozzle diameter as I have stage 3 plans for the winter and will be doing those things next spring, I donít see any sense in going that in depth right now when the ski will only be used in this configuration for another month or two). My theory is the missing material may be causing a slightly lower pressure in the pump post impeller and may be the reason for the slightly high rpm for the mph Iím getting. I do find it odd that I donít notice any other pump damage or hard cavitation signs besides the cone.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	629F7045-7DDF-417C-AB57-172055DE69CC.jpg 
Views:	257 
Size:	37.8 KB 
ID:	466212  


  2. #2
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    819
    +1
    159
    Seems to me that the previous owner might of been messing around with the cone or it was a really bad casting from the factory. Especially since you say there’s no other damage to the pump. Pull the pump and make sure you don’t have cavitation damage on wear ring and impeller edges

  3. #3
    Quote Originally Posted by BLASTER 1 View Post
    Seems to me that the previous owner might of been messing around with the cone or it was a really bad casting from the factory. Especially since you say there’s no other damage to the pump. Pull the pump and make sure you don’t have cavitation damage on wear ring and impeller edges
    A bad casting is what’s making sense to me right now. I doubt someone would intentionally try to remove material, at least not with a result that looks like this. And yes, I’ll be pulling the pump for a more thorough inspection when the new cones come in

  4. #4
    Quote Originally Posted by BLASTER 1 View Post
    Seems to me that the previous owner might of been messing around with the cone or it was a really bad casting from the factory. Especially since you say thereís no other damage to the pump. Pull the pump and make sure you donít have cavitation damage on wear ring and impeller edges
    A bad casting is whatís making sense to me right now. I doubt someone would intentionally try to remove material, at least not with a result that looks like this. And yes, Iíll be pulling the pump for a more thorough inspection when the new cones come in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP 300 Pump Tail Cone and Pump O-Ring Question
    By riverrunner808 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-24-2018, 07:43 PM
  2. Lucky 13 adjustable pump cone for OEM Yamaha and Riva Race Pump's are now available
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 169
    Last Post: 10-31-2017, 07:40 PM
  3. pump cone removal and install of Lucky 13 cone, can it be done without removing pump
    By macattack in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-16-2016, 10:01 AM
  4. rxp pump cone... how much grease goes in the pump cone?
    By FullTilt429 in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-10-2011, 07:01 AM
  5. WTB 05 pump cone or R&D pump cone
    By om1ros in forum Yamaha Classifieds
    Replies: 6
    Last Post: 11-24-2009, 10:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •