Results 1 to 7 of 7
  1. #1

    2009 Sxr 800 hole shot problems

    Hi. Iím new to the jet ski world. I just picked up a 2009 SxR 800. The ski runs amazing. Tons of power. It has a factory wet pipe. Reeds. Novi carbs with filters. Skat trak pump and prop. Ride plate and aftermarket grate. The ski has a real hard time getting out of the hole. I seem to be blipping the throttle a lot. Once the ski is moving it hooks up and is crazy powerful. Itís almost like it is calvating a lot. Pump is good. Prop is good. Wear ring is good. Seems to me like there is a ton of blow by tho. Any help whatsoever would be greatly appreciated. Thanks.

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,774
    +1
    771
    Welcome aboard, Fat4duck!

    It takes very little to cause a problem in the jet pump. A piece of fishing line, a piece of wood the size of a match stick. Carefully inspect the pump for anything like that. Also, check the condition of the impeller blades. Dings will slow you down. Clearance between the impeller and housing should be about .025" or less. Also, check the condition of sealant around the pump tunnel, grate, etc. You want to avoid anything that can cause turbulence in the flow.

  3. #3
    Thanks for responding. I was also told about leakage around the shoe? Is that a replaceable part?

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,774
    +1
    771
    Pretty difficult to replace, but all you need to do is apply sealant around the edges and make sure to smooth it so you don't get turbulence.


  5. #5

    Join Date
    Apr 2007
    Location
    Surprise, AZ via NorCal
    Posts
    224
    +1
    24
    Do you have pump shoe plugs installed? May need to step up impeller pitch if it's not cavitation related. Did you check impeller blade to pump housing clearance?

  6. #6

    Join Date
    Apr 2007
    Location
    Surprise, AZ via NorCal
    Posts
    224
    +1
    24
    Pump Spec's:

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	sxr pump.jpg 
Views:	29 
Size:	217.4 KB 
ID:	465734  

  7. #7
    I’m not sure if it does have plugs or not. Going to really look into it this weekend. Talk to a guy at Skat trak and he said a multiple of things. The clearance doesn’t look to be an issue but I will pull it apart. Thank you all for giving me some really good starting points. It’s nice to see how helpful everyone is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SXR 800 hole shot problems.
    By Fat4duck350 in forum Canada Rides
    Replies: 0
    Last Post: 08-12-2020, 01:19 PM
  2. Any Compatability between Cover for SXR-800 and SXR-1500?
    By Thor in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 03-10-2019, 06:47 PM
  3. 2009 Kawasaki 800 SXR worth
    By haffne in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-12-2012, 03:06 PM
  4. HELP Install Problems! with Aquavein Stealth SXR 800
    By 2SlowinTO in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-16-2010, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •