Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11

    Join Date
    Jun 2020
    Location
    Wasilla Alaska
    Posts
    34
    +1
    1
    Perfect. Thanks so much.

  2. #12

    Join Date
    Jun 2020
    Location
    Wasilla Alaska
    Posts
    34
    +1
    1
    I was able to chat with Darrin this morning. I think we have a path forward on the EMM.

    This morning I was able to reassemble the entire ski. I have a very short list of things missing. Bendix, starting solenoid and flywheel. I was able to find every bolt, nut, clamp, etc. and where everything goes with only a few exceptions.

    I have a small 2 wire plug that dangles near the middle of the throttle body. Black/red blue. What does this plug in to? I may have a sensor that is missing or i cant seem to find it. Pic below.

    I also found a clamp and small allen screw in the hull. What is this clamp for. I also found the bendix spring and 2 bendix thrust washers in the hull. The parts diagram shows this motor only needs one bendix thrust washer. I cant imagine why there were 2.

    Any clue what this clamp goes to and where to look. Pic below.





    Here it is as it sits all assembled but not yet running. Still needs a thorough cleaning.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	4BD193C5-3DEE-4FDE-BB80-5D5786002EEF.jpeg 
Views:	33 
Size:	23.7 KB 
ID:	465794   Click image for larger version. 

Name:	F5FA3B68-488C-47AC-828A-8F0EF399CE48.jpeg 
Views:	26 
Size:	24.6 KB 
ID:	465795   Click image for larger version. 

Name:	40B161BB-AF79-4AB8-9627-D6E1C23B5478.jpeg 
Views:	29 
Size:	18.6 KB 
ID:	465796   Click image for larger version. 

Name:	CA752CF5-DA2A-49A0-8938-567D276155C7.jpeg 
Views:	28 
Size:	153.3 KB 
ID:	465797  

  3. #13
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,966
    +1
    2,226
    Bracket looks like it holds the large Ficht capacitor in place.



    The loose connector is for the air temp sensor. The temp sensor is mounted to the bottom side of the flame arrestor base plate. The actual sensor top is visible in the photo.

    Note that it is common for the sensor to to be cut by the plastic web of the flame arrestor cover. Trim the plastic a little so it cannot contact the sensor.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1B48F134-B5DC-4785-80D2-7EC50649CCEF.jpeg 
Views:	28 
Size:	45.7 KB 
ID:	465798  


  4. #14

    Join Date
    Jun 2020
    Location
    Wasilla Alaska
    Posts
    34
    +1
    1
    Quote Originally Posted by K447 View Post
    Bracket looks like it holds the large Ficht capacitor in place.



    The loose connector is for the air temp sensor. The temp sensor is mounted to the bottom side of the flame arrestor base plate. The actual sensor top is visible in the photo.

    Note that it is common for the sensor to to be cut by the plastic web of the flame arrestor cover. Trim the plastic a little so it cannot contact the sensor.
    Oh man, I can't believe I missed that. I looked the throttle bodies over pretty good before dropping them into place. I didn't really see that wire and plug until I had the TB sitting on the manifold. Oh well, won't miss that one again.

    Where is the large Ficht Cap supposed to be located on a TXi? I didn't see a capacitor anywhere.

    Thanks for the help.

  5. #15

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    198
    +1
    12
    FYI... the air temp sensor was missing its water seal... it's a weather pack and so should have a seal. Be sure to pack it with dielectric silicone or something similar if you can't find the seal.

    The capacitor mounts to the bottom of the EMM bracket... it's about 2" in diameter and is covered by a rubber boot.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2002 Virage TXi hull and body parts ONLY
    By HiPeRcO in forum Polaris Classifieds
    Replies: 13
    Last Post: 11-08-2016, 08:07 PM
  2. My first 2002 Virage TXI project.
    By HiPeRcO in forum Polaris Projects
    Replies: 17
    Last Post: 07-20-2016, 11:09 PM
  3. Replies: 9
    Last Post: 06-06-2013, 09:47 AM
  4. FS 2002 Virage TXI and 2003 Virage I with Double Trailer
    By dalepatter in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-25-2010, 05:01 PM
  5. WTB Badly need 2 parts for 2002 Virage TXI 1200 ASAP
    By tenjuna in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-10-2010, 11:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •