Results 1 to 4 of 4
  1. #1

    Spark plug reading, should I check anything else?

    I was just fighting problems of my 2012 Rxpx-260 not getting over 35mph. First thing I did was check the plugs and the middle plug looked like it wasnít firing. I replaced all plugs and tried again and didnít change anything.

    i had this happen before when the oem intercooler failed(but I didnít check the plugs when that happened so didnít know what they looked like. Iíve since replaced the oem intercooler with a fizzle that I just installed, and while I was waiting I installed a new supercharger as mine had never been rebuilt and the impeller didnít look good due to salt from the first failed intercooler.

    Iím just finishing up reassembling everything and am replacing the plugs again and see the middle plug still looks different from the other 2. Is this due to the intercooler failure and water getting into the intake? Or is there something else I should check that Iím not thinking of before buttoning you the ski and testing everything again?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	032ED1D7-B20D-4AD2-8D71-DFEA827D106E.jpg 
Views:	25 
Size:	31.2 KB 
ID:	465512   Click image for larger version. 

Name:	6CA81FDE-2126-4C96-8170-6576A2D6AD30.jpg 
Views:	104 
Size:	85.6 KB 
ID:	465513  

  2. #2
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    837
    +1
    46
    Quote Originally Posted by bsimms89 View Post
    I was just fighting problems of my 2012 Rxpx-260 not getting over 35mph. First thing I did was check the plugs and the middle plug looked like it wasnít firing. I replaced all plugs and tried again and didnít change anything.

    i had this happen before when the oem intercooler failed(but I didnít check the plugs when that happened so didnít know what they looked like. Iíve since replaced the oem intercooler with a fizzle that I just installed, and while I was waiting I installed a new supercharger as mine had never been rebuilt and the impeller didnít look good due to salt from the first failed intercooler.

    Iím just finishing up reassembling everything and am replacing the plugs again and see the middle plug still looks different from the other 2. Is this due to the intercooler failure and water getting into the intake? Or is there something else I should check that Iím not thinking of before buttoning you the ski and testing everything again?

    If you have a candoo, you can test each spark plug with the ignition coil. To verify if the plugs are igniting/putting a spark out.. You can also Ohm out all 3 x ignition coils. 2.4 ohms each approx.

  3. #3
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    837
    +1
    46
    This is also posted in the incorrect section of the forum..


  4. #4
    Thanks. Which section should it be posted in if not the 4-Tec seadoo section? I’m

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OHM NOOB 5.19,4.39,3.54 reading off spark plug caps w/o boot on
    By NJjetskiguy in forum Polaris Tech Tips and Info
    Replies: 10
    Last Post: 05-31-2019, 07:18 AM
  2. Spark plug tube rubber seal fix / oil on spark plug
    By Drakeremoray in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-28-2019, 07:19 PM
  3. New XL800 spark plug check
    By XL800Paul in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-26-2018, 04:15 PM
  4. Spark plug reading ?
    By Greggpru in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-15-2016, 06:44 AM
  5. Spark Plug Reading
    By la90043 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-02-2008, 07:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •