Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33
  1. #1

    2016 FZR, broken intercooler?

    Hey.

    FZR with Riva Stage 2 kit, runs ok when cool. But when it get hotter there’s a powerloss and it starts to ”missfire”. Do we have a broken intercooler or is something messed upp with the cams or trigger wheel ?

    Link to youtube clip for demo.


  2. #2
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    699
    +1
    66
    I had a leaking Fizzle, it would "load up" with water when crusiing and then you stab throttle and it would hesitate until the water built up was gone and then run fine.

    Felt like a 2 stroke and loading the plugs up and then you romp on it and takes a few seconds to clear the out and then take off screaming.


  3. #3
    Quote Originally Posted by mittens View Post
    I had a leaking Fizzle, it would "load up" with water when crusiing and then you stab throttle and it would hesitate until the water built up was gone and then run fine.

    Felt like a 2 stroke and loading the plugs up and then you romp on it and takes a few seconds to clear the out and then take off screaming.
    Thanks for the response.
    Did you have to replace the whole intercooler or where you able to fix the leaking fizzle?

  4. #4
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    699
    +1
    66
    Would note if you ran it hard it never gave issues, just after cruising. if running hard it was sucking the leak in while running haha.

    I still have the fizzle under the work bench, not sure what or who could fix it. as the leaks in the core which is inside the metal box... probably trash.

  5. #5
    Quote Originally Posted by mittens View Post
    Would note if you ran it hard it never gave issues, just after cruising. if running hard it was sucking the leak in while running haha.

    I still have the fizzle under the work bench, not sure what or who could fix it. as the leaks in the core which is inside the metal box... probably trash.
    Hehe ok.
    Well, I guess I need to pressure test the intercooler anyway.

  6. #6
    Egeiger81's Avatar
    Join Date
    Jun 2020
    Location
    Nashville
    Posts
    75
    +1
    7
    I just posted about my leaky intercooler yesterday on my 2009 FZS. There’s a thread about it with videos and pics of all the water in the system.

  7. +1 by:


  8. #7
    Ok so the intercooler is preassure tested both with air and in water with the hose separated from throttle body. No air leak and no water coming from hose.

    So I’m back at square One.

    Any suggestions on what could be causing this?

    The ski runs great when cold and revs around 8k but after a couple of minutes it slowly starts to act like this and the rev decreases to 7k flat.

  9. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,853
    +1
    3,077
    Quote Originally Posted by FloatR View Post
    Ok so the intercooler is preassure tested both with air and in water with the hose separated from throttle body. No air leak and no water coming from hose.

    So I’m back at square One.

    Any suggestions on what could be causing this?

    The ski runs great when cold and revs around 8k but after a couple of minutes it slowly starts to act like this and the rev decreases to 7k flat.

    Have you tried changing the spark plugs?
    You could also have a bad ignition coil.

  10. #9

    Join Date
    Nov 2018
    Location
    North Carolina on Jordan Lake
    Posts
    627
    +1
    82
    Quote Originally Posted by FloatR View Post

    The ski runs great when cold and revs around 8k but after a couple of minutes it slowly starts to act like this and the rev decreases to 7k flat.
    To me that sounds like a spark plug that is getting hot and shorting out to ground. Replace the spark plugs and I think you will solve your problem. These engines are very hard on spark plugs and need to be changed often. Make sure you correctly gap the spark plugs before you install them and hit them with a little bit of anti-seize so you never pull the threads out of the head. This is the part number for your spark plug and this is your gap for them. NGK LFR7A Spark Plug Gap .35

    Get back to us and let us know how things go.Take care
    CJ

  11. #10
    Egeiger81's Avatar
    Join Date
    Jun 2020
    Location
    Nashville
    Posts
    75
    +1
    7
    What oil are u running? Could the supercharger clutch be slipping? Have u tested the clutch by trying to spin it both directions.

    my clutch felt fine but i could get it to move backwards by like 1 degree at a time by wiggling it back and forth with my finger. It finally gave out a week ago now it’s nice and tight and won’t back up at all. Could be when it gets hot it starts to slip?

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warranty Bulletin : Broken Intercooler Strap
    By brpcare in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-08-2017, 11:42 AM
  2. 2016 fzr or 2016 gp1800
    By Boog91 in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 04-06-2017, 01:09 AM
  3. Replies: 2
    Last Post: 02-27-2017, 09:16 PM
  4. 2015 FZR vs. 2016 FZR. Improved timing chain? Any other enhancements? Paint? Hull?
    By dolphinride in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 12-23-2015, 04:49 AM
  5. Broken intercooler after 4 hours
    By MrIgor in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-02-2013, 05:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •