Results 1 to 6 of 6
  1. #1

    Question 08 ultra 250x pisser

    08 Kawasaki ultra 250x, with 57hrs has been sitting for 3 years. I bought this thing July 4th weekend. After doing the pump upgrade and a few other little things after getting it running.The pisser had no water when on the water hose. So I cleared the line and it worked. this weekend I hit the water and it was working fine. After about 20 minutes water stopped coming out the pisser and I parked it and came home. I put it on the water hose again and water was coming out. Well today at the lake again. I was heading out and I noticed hot water was get on my foot and coming from under the front compartment hood. I opened it and I for got to put the flush cap on. (Water was shooting out 2 feet) No big deal. Water was coming out and it was HOT... After putting the cap on and riding 10 or so minutes. It stop pissing water again. I pull up next to the dock and unscrewed the flush line. Water would only come out when I give it gas.. not like before it was shooting like 2 feet in the air at idle... any help would be appreciated.


  2. #2
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    588
    +1
    41
    You may have a small amount of debris that got loose and clogs it up. Itís a small line and can happen fairly easily. If you ride salt Or have in the past then run salt away and do the heavy desalting procedure. Water alone is not sufficient to flush out salt build up. Water coming out the flush port while the ski is running would be about the hottest water the engine could produce. Should be no real problem as long as your temp sensor is working well

  3. #3
    Quote Originally Posted by dcuhpw View Post
    You may have a small amount of debris that got loose and clogs it up. It’s a small line and can happen fairly easily. If you ride salt Or have in the past then run salt away and do the heavy desalting procedure. Water alone is not sufficient to flush out salt build up. Water coming out the flush port while the ski is running would be about the hottest water the engine could produce. Should be no real problem as long as your temp sensor is working well
    Ok, I'll get some ordered today. It has been in saltwater from what the old man told me. I got a good deal on it, I just couldn't pass it up. It's been 10 years since I've owned a PWC. That 99' XP is nothing like this ski... The power is amazing for sure. Looks like I'll be ordered a new exhaust water box and cold air intake soon. Thanks for the advice.

  4. #4
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    588
    +1
    41
    Quote Originally Posted by 08 ultra View Post
    Ok, I'll get some ordered today. It has been in saltwater from what the old man told me. I got a good deal on it, I just couldn't pass it up. It's been 10 years since I've owned a PWC. That 99' XP is nothing like this ski... The power is amazing for sure. Looks like I'll be ordered a new exhaust water box and cold air intake soon. Thanks for the advice.
    Just know that this ski is going to be way more upkeep than an old 2 stroke. Spray fogging oil into that supercharger after every ride. Also, upgrade the jet pump to the newer style triple bearing setup with nut. A pump failure often times destroys the engines on these machines. Just make sure you have those essentials done before any upgrades. Also, grab the factory service manual and follow the maintenance procedures. You’ll need check things like valve adjustment.

  5. #5
    Quote Originally Posted by dcuhpw View Post
    Just know that this ski is going to be way more upkeep than an old 2 stroke. Spray fogging oil into that supercharger after every ride. Also, upgrade the jet pump to the newer style triple bearing setup with nut. A pump failure often times destroys the engines on these machines. Just make sure you have those essentials done before any upgrades. Also, grab the factory service manual and follow the maintenance procedures. You’ll need check things like valve adjustment.
    Yeah, that was the first thing I did was the pump upgrade and fogging oil. Thanks for the info. I appreciate it.

  6. #6
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,187
    +1
    362
    Those are bad about one of the cooling lines popping off at the rear. Just take out the 10mm bolts holding the rear seat support onto the hull and look back where they hook to the pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki ultra 250x low pisser :(
    By xRallyArt in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 04-29-2019, 01:33 PM
  2. Ultra 150 triple pisser
    By Joyride8 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-30-2011, 07:05 AM
  3. plug and pisser problems with my ultra
    By Jmski333 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-16-2009, 09:46 AM
  4. ULTRA 250X vs ULTRA 250X WITH RIVA RIDE PLATE
    By ULTRA 250XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 09-10-2007, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •