Page 1 of 11 123 ... LastLast
Results 1 to 10 of 107
  1. #1

    2003 Polaris Genesis wonít start

    I have 2003 Polaris genesis that wonít start. When the tsp is plugged in we donít have spark. When itís not plugged in we have spark.


  2. #2
    It has the ficht engine

  3. #3

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    198
    +1
    12
    So it's a Genesis i? And with the throttle position sensor (TPS) plugged in you have NO spark, unplug it and you have spark? Is this correct?

    I would first check the TPS -> read here and scroll down to the TPS section

  4. #4
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,370
    +1
    144
    I'm speculating it is an EMM issue, but you should perform some additional diagnostic steps.

    Does it start with the TPS unplugged?

    Measure the DC voltage on white/red wire, 21/45 VDC supply, that feeds power to the injectors. This measurement must be made with everything connected. You'll need to back probe a connector with a small diameter probe, such as unwound paper clip, between the sealing boot and the wire insulation. The white/red wire also appears in the 4-pin diagnostic connector and is likely easier to access there. You should measure approximately 21 vdc while cranking (fully charged battery) and 45 vdc while running.

    If this is low, you'll want to proceed to stator tests next.

  5. #5
    I have also notice when the TPS is plugged in the fuel pump will not pump. Unplugged TPS and it pumped fine. So I unplugged the TPS and poured a small amount of gas down the 3 bodies and the jet ski will run until the gas is gone with high RPM's. With it starting and revving so high I don't try to run it very long.

    Yes it is a Genesis i with a TPS.

    Thanks

  6. #6
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,370
    +1
    144
    Also, check the connections at the large capacitor and make sure the screws are tight.

  7. #7
    Is the capacitor the cylinder looking item that has 2 wires. Red/white and black?

  8. #8
    I think mine is blue with black cap over it.

  9. #9
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,995
    +1
    2,230
    Quote Originally Posted by rsmartin5 View Post
    Is the capacitor the cylinder looking item that has 2 wires. Red/white and black?
    White/Red wire and black wire, of a medium thick wire size


    http://greenhulk.net/forums/showthre...=1#post3089902

  10. #10
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,370
    +1
    144
    Quote Originally Posted by rsmartin5 View Post
    I think mine is blue with black cap over it.

    That's it.

  11. +1 by:


Page 1 of 11 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (1 members and 1 guests)

  1. rsmartin5

Similar Threads

  1. 01 Polaris Genesis FFI turns over but won't start
    By trice in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-20-2018, 04:51 PM
  2. 2002 Polaris Genesis - Won't start!
    By ckohio in forum Polaris Projects
    Replies: 3
    Last Post: 06-30-2017, 08:26 PM
  3. 2003 Polaris Genesis - Backfiring and won't start after sitting for 2 years
    By LuvHartwell in forum Polaris Open Discussion
    Replies: 29
    Last Post: 06-24-2013, 08:54 PM
  4. 2003 Polaris Genesis won't start.
    By toothtech in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 09-13-2009, 08:45 PM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •