Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27
  1. #21
    Quote Originally Posted by steve45 View Post
    So you buy used parts from two different models of 'Skis, put it all together and it ran great, it just has a vibration, and you're going to scrap it and go with a SeaDoo?

    I guess that makes sense...
    Sure....if youíre going to assume I pieced this thing together and made it myself then I appreciate the compliment but I didnít. Found it completed and for sale and I jumped on it. I love the Ultra hulls but considering what I have invested in it and what it could take to chase this issue, Iíd rather part it out and invest it in another ski.

  2. #22
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,761
    +1
    770
    If you're in Texas and want to sell it as it, my nephew may want it. Send me a PM if you decide to sell it.

  3. #23
    Quote Originally Posted by steve45 View Post
    If you're in Texas and want to sell it as it, my nephew may want it. Send me a PM if you decide to sell it.
    Sounds like a plan. I’ll let you know.


  4. #24
    UPDATE:
    Got the new carriage assembly bolted in, driveshaft in, motor back in, everything plumbed and wired.....jet pump is shot. That slight drag that my impeller had on the wear ring turned into major drag real quick. Binds real bad in a few spots. This ski was originally used exclusively in salt water and I knew that when I purchased it. I also knew that the wear ring & impeller would have to be replaced or a whole new assembly I just didn't expect it quite so soon. Took the pump off and the corrosion between the housing and the wear ring is pretty bad. So......I'm now looking for a new pump. I know KP sells complete units but they're pricey. Anyone have any other suggestions where I can look. I'll spring for a good used one if the price is right.

    So just to summarize......slight drag between the impeller and wear ring was the cause of the vibration, trashed my driveshaft bearing, looking for a replacement pump.....in the middle of the season

  5. #25




    for those that want to see

  6. #26
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,761
    +1
    770
    Well, at least it's a fairly simple, though expensive, fix. Getting parts right now may be a problem.

    SBT rebuilds pumps, so you might see what they have to offer.

  7. +1 by:


  8. #27
    Anyone know if a 310 pump will work? I'm sure it'll bolt up, just concerned about any differences in prop pitch or any other specs.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 STX 15f tie strap around driveshaft
    By Smooker in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-15-2018, 09:56 PM
  2. 2006 kawasaki stx 15f engine inside a 2008 kawasaki stx 15f
    By Transport25 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 05-20-2017, 10:41 PM
  3. STX-15F Driveshaft Bearings
    By CJ River Rider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 02-02-2015, 10:17 PM
  4. STX-15F 2003 crankcase and Crank fit to 2010 STX-15F ?
    By polarex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-26-2014, 04:05 AM
  5. FS - Parts intake grate WORX 219 STX 1200, STX-R, STX 12F STX 15F kawasaki
    By elviswongg in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 10-09-2012, 12:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •