Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Quote Originally Posted by RiverRat71 View Post
    Sorry, didnt see where you stated it had a tune. Sounded like you were way over revved & ecm was pulling timing. Personally I would sleep better knowing what kind of tune it had. RR
    sure i will also sleep better but no change to know i have none information what tune it is. I have also orginal ecu and i tested it works but i have ride it with tune.
    this tune ecu runs idle Speed rpm 2400.
    there was o2 bung when i buy it. O2 gauge shows super rich 9-9.5.
    but o2 sensor hole was done to y-pipe stretch area and It leak like hell,
    i was scared that whole thing would burn. Now there are orginal y-pipe
    without o2 sensor.

  2. #12
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,805
    +1
    219
    That idle speed is odd, 2400 rpm is way too high. Which may be an indicator of your problem.
    There seems to be a vaccumm/boost leak to cause that high idle. Did it idle high with the stock ECU?
    Take a really good look at your intake manifold, it may be cracked.
    As for cleaning the inter cooler, if there is no water strainer on the ski and it was rode it water with dedris like weeds, it can get plugged up, you need to reverse flush it and see it junk comes out.

    Oh and do a compression check.

    Is it running an aftermarket intake grate?

  3. #13
    Quote Originally Posted by SplishSplash View Post
    That idle speed is odd, 2400 rpm is way too high. Which may be an indicator of your problem.
    There seems to be a vaccumm/boost leak to cause that high idle. Did it idle high with the stock ECU?
    Take a really good look at your intake manifold, it may be cracked.
    As for cleaning the inter cooler, if there is no water strainer on the ski and it was rode it water with dedris like weeds, it can get plugged up, you need to reverse flush it and see it junk comes out.

    Oh and do a compression check.

    Is it running an aftermarket intake grate?
    Thanks for respond.

    Stock ecu idles 1850-1900.
    No water strainer.
    I will assembly the strainer to the hose line before intercooler IN ?
    Dont know the grate but i think its orginal (previous owner does not listed it to the changed parts)

  4. #14
    Yesterday we were in lake with rxt.

    we got check engine and limp mode and code 1202

    oil level is too low we rise oil level to middle
    of the stick (oil
    check was done correctly warming up, 30sec idle
    30sec after engine stop)

    Today test With correct oli level the engine check / limp mode
    comes still after 7000-8000rpm. Stop engine and running
    gain with 5000rpm no limp but after open throttle acceleration
    it comes at once. Both times today check engine/limp but no codes.

    should to change oil sensors ?

    also we have the compass code there which come two days after buy
    the ski. But that code does not affect anything. When compass code come up i change orginal ecu and think code cannot be with another ecu but code stay still with another ecu. Where is those codes ? They cannot be in ecu. Are codes in speedo gauge ?
    This ski does not have compass at all, so if that compass code keeps stay on failure then that code indication something else that are in ski but no compass (no compass whole ski).

  5. #15
    Quote Originally Posted by TimFin View Post
    Yesterday we were in lake with rxt.

    we got check engine and limp mode and code 1202

    oil level is too low we rise oil level to middle
    of the stick (oil
    check was done correctly warming up, 30sec idle
    30sec after engine stop)

    Today test With correct oli level the engine check / limp mode
    comes still after 7000-8000rpm. Stop engine and running
    gain with 5000rpm no limp but after open throttle acceleration
    it comes at once. Both times today check engine/limp but no codes.

    should to change oil sensors ?

    .
    change front oil sensor and no code / limp mode.
    It work and run no problems but ~65-68mph.

    Something odd there are that’s what i think
    there should be more speed.
    impeller damage, boost line leak etc.
    All check’s go after season end when pick up
    jet to garage. Hope it not blow up before that.


  6. #16
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,309
    +1
    213
    Sounds like you have a Rotax Racing ECU and 8550 is the limit and it's mapped for 42lb injs. You're running way too fat on top, Toss in some 42's and see what you get for AFR @ top rpm. 8400-8450 is a good target for rpm.
    Get a Manifold tapped for the o2 sensor and ride... Your setup is mild, an X charger with IC and ecu should get you to 71 - 73mph, your boost is close to where it should be, 11-12lb @ 8450 ..

  7. #17
    Quote Originally Posted by ou812 View Post
    Sounds like you have a Rotax Racing ECU and 8550 is the limit and it's mapped for 42lb injs. You're running way too fat on top, Toss in some 42's and see what you get for AFR @ top rpm. 8400-8450 is a good target for rpm.
    Get a Manifold tapped for the o2 sensor and ride... Your setup is mild, an X charger with IC and ecu should get you to 71 - 73mph, your boost is close to where it should be, 11-12lb @ 8450 ..
    Thanks for information and respond

    I will inspect that y-pipe where o2 bung was if it can do so it wont leak.
    I think that pipe is lost. When leaking pipe eas in ski O2 was strongly
    rich. I found that impeller should be 2015 260hp ski´s with somekind mods.

    I will update when i get done something.

  8. #18
    Quote Originally Posted by TimFin View Post
    I found that impeller should be 2015 260hp ski´s with somekind mods.

    I will update when i get done something.
    anyone knows, thanks:

    whar is faster impeller 260/2015 orginal vs 14/19 ?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp-x300 8300rpm impeller?
    By Loth in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-12-2020, 02:26 PM
  2. 2005 seadoo rxt super charger question
    By spray&Splash2011 in forum 4-Tec Performance
    Replies: 12
    Last Post: 10-21-2012, 10:03 AM
  3. Please make prop recommendations - 2005 RXT w/X-charger
    By ghlenz in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-31-2012, 08:54 PM
  4. FS 2005 RXT Super Charger.. CALI!
    By xpl2008 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 10-12-2009, 03:56 PM
  5. Close call on Super Charger 2005 RXT Pics!!
    By xpl2008 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-03-2009, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •