Results 1 to 8 of 8
  1. #1

    Join Date
    Jun 2014
    Location
    MRSHFIELD WISCONSIN
    Posts
    136

    Msx 140 broken stator pump bolt

    Hi all. I removed my stator pump on my msx 140. 3 bolts came out really hard and the 4th one snapped off were it goes into the threads on hull. What do i do to fix this. Any help would be appreciated.

  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,120
    +1
    257
    That is a very difficult problem to resolve. Removal of the pump base is likely required, which is difficult without removing the ride plate which is also difficult. (Trying to drill out the broken bolt in situ is nearly impossible...)


  3. #3

    Join Date
    Jun 2014
    Location
    MRSHFIELD WISCONSIN
    Posts
    136
    Boy thats not good news. What do i do? Do i have to pull the motor to get it off or what is the prosess to do it. I some how have to fix it. I cant leave one bolt wreck the whole ski. My anxiety just went crazy

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,120
    +1
    257
    You don't have to pull the motor. I personally would craft a pump base puller, leaving the ride plate alone. (I have had ride plates bend before becoming detached from the hull...)

  5. #5

    Join Date
    Jun 2014
    Location
    MRSHFIELD WISCONSIN
    Posts
    136
    I certainly appreciate your help but if you could be more specific on how to change this. I found a housing on ebay but after looking at this closer it look as tho it is bolted thru the hull to the inside motut or compartment by 4 bolts. They look inaccessible with 2 covered pretty much by the foam from the emm and battery and the other 2 from the exhaust can. Or am i looking at this wrong. This is a 2004 msx 140. If you or someone could give me instructions on how to change this it would mean the world to me. Also what type of sealant is used between the pump housing and the hull. Thankyou

  6. #6

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    463
    +1
    45
    Never attempt to drill broken fasteners out. It only makes matters worse. I usually mig or tig weld a tip and build up on the broken fastener. Then put a nut on the tip and hammer the heat and weld the nut on. Might do this a few times. I just finished one today. This took about 15 minutes to do. Albeit you may have to take the engine out in your situation. I have only once in 20 years drilled out a broken fastener that is because when the customer brought it to me to extract the part he had an easy-out broken in there and I had to use a carbide end mill on my brigdeport to get it out.



    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20200714_143701.jpg 
Views:	48 
Size:	74.7 KB 
ID:	464407   Click image for larger version. 

Name:	20200714_142221.jpg 
Views:	45 
Size:	81.4 KB 
ID:	464408  

  7. #7

    Join Date
    Jun 2014
    Location
    MRSHFIELD WISCONSIN
    Posts
    136
    Thanks for the info. I will give that a try. I dont have a welder so i will try to find someone. If it doesnt work and i have to replace the housing do i have to do an engine alignm.ent after its replaced

  8. #8

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    463
    +1
    45
    Quote Originally Posted by car22car View Post
    Thanks for the info. I will give that a try. I dont have a welder so i will try to find someone. If it doesnt work and i have to replace the housing do i have to do an engine alignm.ent after its replaced
    Oh and a 110v welder aint gonna cut it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 08-29-2019, 04:12 PM
  2. 2003 MSX 140 step bolt length?
    By Jetskijunky in forum MSX/Matrix
    Replies: 1
    Last Post: 07-31-2017, 05:57 PM
  3. MSX 140: water temp sensor bolt size
    By beachin407 in forum Polaris Projects
    Replies: 2
    Last Post: 05-31-2017, 01:22 PM
  4. MSX 140 Head Bolt O-rings or Sealant ??
    By SMOKEWAGON in forum MSX/Matrix
    Replies: 0
    Last Post: 06-26-2009, 09:09 PM
  5. MSX 140 - May Need New Stator
    By Koodat in forum MSX/Matrix
    Replies: 13
    Last Post: 05-07-2009, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •