Results 1 to 8 of 8
  1. #1

    2012 GTI stopped recognizing DESS key

    My 2012 SeaDoo GTI SE 155 stopped recognize the DESS key last week. It would not give the double beep. I have 2 keys, and same with both. After being on for a while, it gives a single beep periodically indicating that the key is plugged in. I can hear the fuel pump prime when I press the start button as well as when I put the key on the post.

    I took it out the week before with no problem. I also flushed it when I got home. My battery was reading 12.3volts.

    My display LCD is fully burnt black (unrelated) so I don’t know if it is giving a message on the screen. It functioned for a long time with the LCD burnt without issues. The only thing I can read is the hours.

    What troubleshooting steps can I take?

  2. #2
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    766
    +1
    77
    Try to spray the key and post with anti corrosion spray like XPS.
    I have the same now then with the old type DESS system.
    After it works great again.


  3. #3
    If I remember right there was a bulletin on this. Not sure what yr but it was 09 and newer. It was a ecm flash

  4. #4
    Quote Originally Posted by EVN81 View Post
    Try to spray the key and post with anti corrosion spray like XPS.
    I washed off the post and key with soap and water with no change. Do you think the anti-corrosion spray will make a difference?
    have you ever had it stopped recognizing it completely?

    Quote Originally Posted by ski doo zx 800 View Post
    If I remember right there was a bulletin on this. Not sure what yr but it was 09 and newer. It was a ecm flash
    what was the bulletin about? DESS key not being recognized and fixed with a ECM flash? Was that a recall or just a bulletin of how the dealer would fix it?

    I carried the ski to my trusty neighborhood jetski mechanic and he was stomped. He recommend the dealer :-/

  5. #5
    Yes it was just a bulletin about the dess key not being recognized. The fix was a ecm flash. It was not a recall. I'll look into my list of bulletins and see if I can find it

  6. #6
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    766
    +1
    77
    Quote Originally Posted by professorman View Post
    I washed off the post and key with soap and water with no change. Do you think the anti-corrosion spray will make a difference?
    have you ever had it stopped recognizing it completely?
    Only the dash wakes up and keeps showing message “reading key” and eventually a long beep. After I spray the XPS it also pops on much smoother. I don’t understand it fully but it always works

  7. #7
    The gauge just says “reading key”. I spray with WD40 and it didn’t work.

  8. #8
    Found the bulletin for this. Intermittent Tether cord recognition. 2010-0009

    Solution with ecm update

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 Seadoo XP computer not recognizing key. Please help
    By TRScars in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-23-2011, 05:07 PM
  2. Replies: 0
    Last Post: 05-17-2011, 04:13 PM
  3. DESS key not working but learning key does
    By Blowout in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 08-29-2010, 08:33 PM
  4. WTB DESS KEY
    By ultramaxracing05 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-02-2010, 02:23 AM
  5. Dess key
    By joaqslam in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-01-2010, 02:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •