Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33
  1. #11
    Remove the nose cone and buy a spline tool for the impeller

  2. #12
    Found my problem I believe.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	70042DD5-C547-4477-A8E6-5B828EF16985.jpg 
Views:	41 
Size:	92.3 KB 
ID:	464280  

  3. #13
    Yeah thats not good, pull the drive shaft and start the ski

  4. #14
    I believe I found the problem. How do I get the impeller off?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	C75C0835-451F-4EAC-89CF-B94DB03EAE34.jpg 
Views:	35 
Size:	92.3 KB 
ID:	464290  

  5. #15
    What do you mean?


  6. #16
    With a spline tool and a vice

  7. #17
    That’s what I thought. Time to head to the tool shop for a spline tool. Are there certain sizes? What size do I need?

  8. #18
    Also is there rebuild kit for the impeller bearing?

  9. #19
    You mean the pump? Yes check wsm website

  10. #20
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,989
    +1
    2,186
    couple of things:

    your not going to have an easy time of this

    you need:

    a really good ( and I mean good ) bench vise solidly mounted

    good breaker bar and likely a cheater bar

    high quality 1/2 drive socket for your spline tool

    propane torch

    lots and lots of luck

    to replace the bearings

    shop press

    more luck

    I'd suggest going with the OEM bearings and seals for a couple of bucks more then the WSM stuff

    remember to always pull on the breaker bar and keep in mind that many a vise have been broken trying to get props off. cheap ones won't do the job ( maybe once)

    I'd rate the job as requiring at least a 7 skill level out of ten

    the pumps usually go from 50-100 hours before needing bearings. run it on the hose too much?..I've seen them blow to bits with only 40 hours on them from that.

    the prop will need a refurbish if the edges have been flattened from grinding on the wear ring.

    at least you were able to get the pump off without help, that's kinda rare these days.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. 02 Ultra 130 DI wont rev past 4000 rpm
    By ryanp in forum Kawasaki PWC Performance (2-stroke)
    Replies: 27
    Last Post: 09-27-2017, 05:11 PM
  2. 1999 polaris slth won't Rev past 4000 rpm
    By Jbrann in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-31-2016, 10:20 AM
  3. 99 GP will not rev past 4000 rpm
    By grumpy in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-20-2013, 03:05 AM
  4. virage will not rev over 4000 rpm in water
    By dloye in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-17-2011, 08:51 PM
  5. ultra 150 wont rev past 4000 rpm
    By jramos in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 07-15-2008, 06:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •