Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    2002 Polaris Genesis i 1200 engine damage what could have caused it.

    The damage is already done its my brothers jetski and i've been taken care of it for him we have had it since 2017 and haven't had any issues yet just normal maintenance. We went out riding for over a hour and it was running fine no issues at all then it acted like it was starving on fuel to best describe it, we were 15 miles out in the lake when it happened so i had to end up towing him back with mine, got it home took apart all the gas lines fuel tank drained all the gas as it was last years gas that we were burning up put new spark plugs on put it back together took it out the following weekend ran for about 30 minutes and it stalled out yet again but this time it fired back up and ran very rough wide open throttle was about 10mph and he limped it back like that got it home it didnt want to idle so i fired it up for about 15 seconds to feel which cylinder head were getting hot to see if all were running the pto "3rd in the back" wasnt getting hot at all so i took the head off to fine this.

    I'm surprised a engine can even run like this, also to add on there is no scoring to the cylinder wall at all.
    What could have caused this amount of damage from what i can tell the previous owner had it taken in to get the pto serviced before as it has a newer fuel injector and has the tags on it from a shop doing a compression test. I'm a welder by trade and to me it looks as if someone was just starting to learn how to weld and tried to stick weld aluminum.


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20200709_185340781.jpg 
Views:	194 
Size:	109.0 KB 
ID:	464231   Click image for larger version. 

Name:	IMG_20200709_185302596.jpg 
Views:	191 
Size:	112.4 KB 
ID:	464232   Click image for larger version. 

Name:	IMG_20200709_185340783.jpg 
Views:	187 
Size:	108.0 KB 
ID:	464233   Click image for larger version. 

Name:	IMG_20200709_185340784.jpg 
Views:	194 
Size:	104.1 KB 
ID:	464234  


  2. #2

    2002 Polaris Genesis i 1200 engine damage what could have caused it.

    i just posted this and i cant find it anywhere and i had everything written out said it posted and i dont see it if it shows up again ill delete this one if it doesnt ill rewrite this tomorrow to make it not so rushed. To sum up what happen we took it out 15miles out it acted like it was starving on fuel and didnt want to fire back up as the battery died, towed it back cleaned up all the gas lines drained out the old gas from last year new spark plugs took them out the next weekend made it about 30 minutes and stalled out it fired back up my brother limped it home wide open as it would stall if he didnt and at wide open it would hit about 10mph got it to fired it up at home the to see if all the cylinders were working and it wouldnt idle had to give it gas, the pto cylinder wasnt getting hot so i took out the spark plug and it would idle i disconnected the tps and put the spark plug back in and still wouldnt idle so i took the head off to find what looked like you took a stick welder to aluminum and there was no scoring at all in the cylinder wall.

    What could cause this kind of damage.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20200709_185340784.jpg 
Views:	196 
Size:	104.1 KB 
ID:	464239   Click image for larger version. 

Name:	IMG_20200709_185340783.jpg 
Views:	197 
Size:	108.0 KB 
ID:	464240   Click image for larger version. 

Name:	IMG_20200709_185302596.jpg 
Views:	189 
Size:	112.4 KB 
ID:	464241   Click image for larger version. 

Name:	IMG_20200709_185340781.jpg 
Views:	192 
Size:	109.0 KB 
ID:	464242  

  3. #3

    Join Date
    Sep 2015
    Location
    Nova Scotia, Canada
    Posts
    387
    +1
    18
    Looks to me like pieces of bearing. Check the rod and crank bearings.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,613
    +1
    2,182
    Quote Originally Posted by Chadillac3006 View Post
    i just posted this and i cant find it anywhere and i had everything written out said it posted and i dont see it ...
    Welcome.

    As a brand new member posting for the very first time, your initial post was flagged for moderation.

  5. #5
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,117
    +1
    257
    Looks like perhaps a combination of mechanical failure, combined with lean burn. Did you ever repair the fuel pressure regulator?

  6. #6
    That makes sense thanks K447 for clearing it up.

  7. #7
    Quote Originally Posted by Mockingee View Post
    Looks to me like pieces of bearing. Check the rod and crank bearings.
    Will do

  8. #8
    Quote Originally Posted by HiPeRcO View Post
    Looks like perhaps a combination of mechanical failure, combined with lean burn. Did you ever repair the fuel pressure regulator?
    I did not sadly never thought to look there.

  9. #9
    Pretty sure it was the fuel pressure reg as it was laying in the bottom of the fuel pump
    Going to attempt to follow what K447 did to fix his http://greenhulk.net/forums/showthre...=220243&page=9

  10. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,613
    +1
    2,182
    Quote Originally Posted by Chadillac3006 View Post
    Pretty sure it was the fuel pressure reg as it was laying in the bottom of the fuel pump

    Going to attempt to follow what K447 did to fix his http://greenhulk.net/forums/showthre...=220243&page=9
    To reinforce the Polaris Ficht fuel pressure regulator be sure to use the threaded hose barb repair method.
    http://greenhulk.net/forums/showthre...=1#post2424525

    Do NOT use the (now deprecated) cotter pin method, and definitely do NOT use the external Kawasaki inline pressure regulator method.
    Last edited by K447; 07-17-2020 at 03:15 PM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage TXi and 1999 Polaris Genesis 1200 Help!
    By Big Willy in forum Polaris Open Discussion
    Replies: 22
    Last Post: 01-23-2016, 11:31 AM
  2. Just bought a 2002 Polaris Genesis 1200 need Sponsons
    By srps13 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-18-2015, 09:03 PM
  3. 2002 polaris genesis 1 1200
    By elk river rascal in forum Polaris Projects
    Replies: 3
    Last Post: 05-29-2014, 08:31 PM
  4. Replies: 8
    Last Post: 04-08-2014, 10:32 AM
  5. What caused this engine damage
    By iamadam1122 in forum 2-Stroke Performance
    Replies: 27
    Last Post: 07-25-2012, 08:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •