Results 1 to 5 of 5
  1. #1

    Join Date
    Jan 2020
    Location
    Golden Valley, Minnesota
    Posts
    19

    Post 2003 Sea Doo 4-tec Oil Alarm

    My son and I have rebuilt a 2003 Limited GTX with supercharger. We've got it running, but have been struggling with an oil alarm. I know this is a fairly common issue, and have done a ton of research on Greenhulk which has been an invaluable resource. The machine will idle fine, but revving it up will throw the oil alarm around 4,000 RPM's or so and go into limp mode. We've done a ton of research on this issue and have done the following:
    - Replaced both the front and back oil pressure sensors (new)
    - Pulled the engine and blew out the oil passages (they were clear)
    - Checked the oil pressure regulator. It had some minor abrasion between the cylinder and the sleeve, but appeared good. Regardless, we had a spare from a parts engine and put in the better of the two.
    - Checked both the primary and secondary oil pumps. Appear fine with minor abrasion, but again using the spare parts we had, but in the better pump components (swapped PTO cover and oil/water pump assembly).
    - Swapped MPEM's (not sure if this would matter, but gave it a try).

    We're still having this alarm. What we've found though is that it resolves once the engine is warm, and we can ride all day without issue. Could this be an electrical issue, or something that is warming up and releasing? One thought I had was that the oil pressure regulator is sticking, and then after heating up releases? What about the shut off solenoid? That engages with the key, but could that be causing this problem? I know the oil alarm is there for a reason, so I am leery of riding it after it warms up, knowing we might have an underlying oil issue.

    Any help would be appreciated.


  2. #2

    Join Date
    Jan 2020
    Location
    Golden Valley, Minnesota
    Posts
    19
    Any thoughts on this would me much appreciated. Thanks!

  3. #3
    Using the correct oil weight? Have you put an oil pressure gauge on to verify if it’s a high or low oil pressure issue? Have you checked both oil pump strainers? Have you checked both oil pumps for debris or excessive wear/scoring/damage?

  4. #4

    Join Date
    Jan 2020
    Location
    Golden Valley, Minnesota
    Posts
    19
    Thanks for the reply. 10W40 oil (non-synthetic), which has been replaced after pulling engine to remove PTO cover and inspect oil passages, check pressure regulator, and replace PTO cover with different oil pump. Also pulled and inspected primary oil pump. Both pumps show minimal/normal wear. Strainers are clean. We're in the process of installing an oil pressure gauge to verify where that's at across the operating range.

  5. #5
    I'll be interested to see what you find. If you do have low oil pressure, remember an oil pump generates volume, not pressure. This might mean you have excessive play/clearance in an oil fed bearing or other area along the circuit that is causing all of your oil to gush out faster than the pump can deliver. Something like forgetting a bearing, or excessively lose bearing cap or similar could provide a big enough space to experience low oil pressure.
    Quote Originally Posted by FightingSioux View Post
    Thanks for the reply. 10W40 oil (non-synthetic), which has been replaced after pulling engine to remove PTO cover and inspect oil passages, check pressure regulator, and replace PTO cover with different oil pump. Also pulled and inspected primary oil pump. Both pumps show minimal/normal wear. Strainers are clean. We're in the process of installing an oil pressure gauge to verify where that's at across the operating range.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2003 SEA-DOO 4-TEC Supercharge Complete Engine 185HP
    By jaguarr2012 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 03-11-2015, 11:14 AM
  2. 2003 Sea Doo Sportster 4-Tec only idles wont rev!! Help!
    By Tara715 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-27-2014, 07:46 PM
  3. Replies: 4
    Last Post: 05-27-2014, 10:33 PM
  4. WTB Gauge cluster for my 2003 sea-doo gtx 4-tec
    By T-DUB in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 08-24-2013, 07:02 PM
  5. FS 2003 sea-doo gtx 4-tec
    By T-DUB in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 06-30-2011, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •