Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    Quote Originally Posted by TheGrayt1 View Post
    I think this is the original oil and filter from the dealer in 2010 since it only has 14 hours. Doubt it is that. The oil looked light brown and clean though he sent a pic. Is it okay to start for 10 seconds like he did or does a ful oil change need to happen first before running it?
    If the oil has been sitting for 10years the filter or oil pan screen could be clogged


  2. #12
    Quote Originally Posted by mike-ultra View Post
    If the oil has been sitting for 10years the filter or oil pan screen could be clogged
    Would an oil change fix that and turn the warning buzzer off? Did the seller do any damage by trying to run it for a few seconds with 10 yr old oil?

  3. #13
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,648
    +1
    749
    Could have damaged the oil pressure sensor, which is right next to the filter.

    I'd be more concerned about old gas than old oil, but change both.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Timing marks on a 2010 stx15f
    By seaya in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 02-17-2017, 09:42 AM
  2. SOLD 2010 stx15f
    By russell in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 07-15-2014, 05:40 PM
  3. Replies: 2
    Last Post: 07-18-2013, 01:19 PM
  4. 2010 STX15F overheating !!!
    By Fasttimez in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-05-2012, 02:43 PM
  5. About To Buy 99 GSX is this a good ski
    By jcohen17 in forum Sea Doo Open Discussion
    Replies: 37
    Last Post: 03-28-2008, 08:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •