Results 1 to 4 of 4
  1. #1
    YudLuz2's Avatar
    Join Date
    Jun 2005
    Location
    Flowood MS
    Posts
    1,704
    +1
    134

    Oil overheat problem on 300 RXP-X

    2016 RXP-X 300 getting code 298 and shows engine oil temperature overheat. Anyone know what to check or the cause of this code?
    Ski goes into limp mode when engine light flashes. Ski runs fine on a cold motor. I have replaced the sensor, it's located right by the oil pressure sensor, it's the same temp sensor as found on the water box and engine water temp sensor. Something is making the oil get to hot, engine will run at 195 degrees, so no issues with the cooling system. Oil cooler looks clean but has not been
    removed. Ski has a stage one riva kit with scom, so its pretty much stock. Super Charger was replaced recently due to the blade blowing apart, inside clutch and gear was not
    damaged , so the motor didn't take on anything from the charger.
    Thanks Ben


  2. #2
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    766
    +1
    77

    Oil overheat problem on 300 RXP-X

    Second thermostat near small heat exchanger for oil cooler stuck?
    Or small heat exchanger clogged?

    The 16-17 300 models had a very complicated closed loop cooling system.

    Click image for larger version. 

Name:	Adjustments.jpg 
Views:	63 
Size:	43.6 KB 
ID:	464028

  3. #3

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    139
    +1
    25
    I wish there was room in the 16 and 17 hull to upgrade to the 18 larger oil cooler! I hate the excess of cooling hoses everywhere and the potential for failure from added parts

  4. #4
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    984
    +1
    65
    Quote Originally Posted by Rxtxruss View Post
    I wish there was room in the 16 and 17 hull to upgrade to the 18 larger oil cooler! I hate the excess of cooling hoses everywhere and the potential for failure from added parts
    put in a 160 thermo and rip all the pipes out and go bk to previous cooling line set up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What oil do I use in my 2017 rxp 300? Struggling to find the correct oil!!
    By riverrunner808 in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-01-2018, 11:41 AM
  2. Running Seadoo RXP 300 out of water, overheat exhaust?
    By jserr68594 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-23-2018, 09:50 PM
  3. Running Seadoo RXP 300 out of water, overheat exhaust?
    By jserr68594 in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-22-2018, 10:00 PM
  4. maptuner x problem on my rxp 300
    By herbie_gutierrez in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-03-2017, 12:40 PM
  5. Overheat problem?
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-14-2008, 08:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •