Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 52
  1. #31

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,142
    +1
    183
    Quote Originally Posted by overboost View Post
    when you are taking ski out water , do any of you give it a few good revvs on trailer to blow water out exhaust?..... if so what rpms are you seeing then?
    An engine should never be run at high speed with no load. It also proves nothing-any engine will reach peak RPM without a load and also there is no need to blow the water out of the exhaust system.

  2. #32
    Quote Originally Posted by jackk0o View Post
    I havenít tried plugs yet. Trust me though, I feel your pain. 60 is real bad though 😳 wonder if itís supercharger or impeller related.
    I also ordered a new wear ring for $70 shipped and will inspect the impeller closely while out. Gonna do plugs first to test and see if I can isolate the issue, then wear ring. My 5 dealers are 4 weeks out and wonít start my spot in line until I bring the ski in, which kills the rest of summer riding. So much for having a warranty if you canít ever get access to a dealer in the summer.

  3. #33
    need for speed's Avatar
    Join Date
    Jul 2014
    Location
    Jersey Shore
    Posts
    237
    +1
    26
    My sea doo 11 hours did 50 mph changed spark plugs does 71 mph its worth the try

  4. #34
    Temp was 70 and low humidity this morning and my ski did 63 vs 61 when it was low 90s temp. Waiting for plugs and wear ring...

  5. #35
    bill321's Avatar
    Join Date
    Oct 2012
    Location
    Lady Lake, Fl
    Posts
    433
    +1
    62
    Had mine out today in the warm Gulf water....water temp 87, air 90's....7600-7700 rpm at best, cooler temps and I see 8000+ rpms and significant acceleration increase. Hot weather really affects performance...

  6. #36

    Join Date
    Jun 2020
    Location
    Illinois
    Posts
    19
    Got out today for a while. 80 degrees, 50ish % humidity. It was a bit cooler than what I’ve ridden in lately. Consistent 7800 rpms, nothing more. 74/75 dash downstream and 70/72 upstream. A little better but still not there.

  7. #37
    Quote Originally Posted by jackk0o View Post
    Got out today for a while. 80 degrees, 50ish % humidity. It was a bit cooler than what Iíve ridden in lately. Consistent 7800 rpms, nothing more. 74/75 dash downstream and 70/72 upstream. A little better but still not there.
    74-75 on dash in hot weather with humidity sounds about right. I have an '18 PX myself with just SCOM and catch can, and I rarely see over 74-75 myself. I live in Florida gulf coast and your speeds seem pretty normal to me. I've seen 76-77 one time, but that was cooler weather going downhill with a tail wind. (Sarcasm, lol). Honestly without a tune and a different prop, you're not gonna get much more. As others have already pointed out, perhaps your prop may be a bit over pitched, but it personally sounds like you're getting what you should with just a SCOM.

  8. #38
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,090
    +1
    430
    Quote Originally Posted by jackk0o View Post
    Got out today for a while. 80 degrees, 50ish % humidity. It was a bit cooler than what Iíve ridden in lately. Consistent 7800 rpms, nothing more. 74/75 dash downstream and 70/72 upstream. A little better but still not there.
    Something is definitely wrong, I had my wifes box stock 2018 tx out yesterday and similar temps. I'm seeing same speeds and rpm @ 500asl.


  9. #39
    I changed the wear ring and filed/smoothed a couple nicks in the impeller and I went from 60 to 63 mph, so there is defiantly still a bigger problem...

    I just noticed the air hose from the inter cooler to the engine is badly crimped, like probably a 70% restriction in the hose diameter at the first bend coming out of the inter cooler. My guess is the inter cooler shifted forward and pushed this tube forward and when it gets hot it eventually deformed. I canít move the inter cooler at all, so for now am gonna try 2 large clamp rings around this crimp in the bend to open more space inside for air to flow, maybe get it to 70-80% of original diameter vs the current 30% and hopefully see a big difference. If the inter cooler is in the right place then Iíll replace the tube.

  10. #40

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,718
    +1
    956
    Quote Originally Posted by MikeR397 View Post
    I changed the wear ring and filed/smoothed a couple nicks in the impeller and I went from 60 to 63 mph, so there is defiantly still a bigger problem...

    I just noticed the air hose from the inter cooler to the engine is badly crimped, like probably a 70% restriction in the hose diameter at the first bend coming out of the inter cooler. My guess is the inter cooler shifted forward and pushed this tube forward and when it gets hot it eventually deformed. I can’t move the inter cooler at all, so for now am gonna try 2 large clamp rings around this crimp in the bend to open more space inside for air to flow, maybe get it to 70-80% of original diameter vs the current 30% and hopefully see a big difference. If the inter cooler is in the right place then I’ll replace the tube.
    Stock IC hoses are the worst, first thing I do is replace them. I think I have an extra set of like new fizzles if your interested PM me.

Page 4 of 6 FirstFirst ... 23456 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video: 2020 Sea-Doo GTX RXT-X 300 vs. 2020 RXP-X 300 Comparison
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 05-06-2020, 12:10 AM
  2. Pulling stickers off RXT-X 300
    By Sandman_73 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-13-2016, 11:33 AM
  3. RXT only turning 7600 RPM and 54 MPH GPS??
    By richte18 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-29-2014, 10:08 PM
  4. 2011 300 LX only pulling 7400 RPM ?? any ideas ??
    By nz253 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 02-23-2014, 07:35 AM
  5. rxt x used to make 8000 rpm now 7600 whats wrong
    By tallybrick in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-05-2010, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •