Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52
  1. #11
    No exhaust leak, all intake and exhaust hoses look good. Damn, was excited to have found a potential solution. 66mph sucks.

    I see full supercharger bars on the dash, and dealer checked for slip last summer and said it was good.

  2. #12

    Join Date
    Jun 2020
    Location
    Illinois
    Posts
    19
    Quote Originally Posted by MikeR397 View Post
    I posted in another thread:

    I have an 18 px and was pulling 8050 rpm at 71mph with scom only (I am 6í6Ē and 285lbs) when it was in the 60s in Michigan and less humid. Now in the 80s i am only able to get 66 mph and 7700 rpm max. This is my last year with the sled and am ordering a new one as warranty will expire, May try a power filter kit from RIVA on the next one but itís defiantly frustrating And noticeable losing 5mph with summer temps. My old 260px did the same thing.

    will check for exhaust leak now, great idea and makes sense! Oil level is good. Wear ring is perfect.
    Thanks for the info. I checked all exhaust/intake lines, made sure oil was in range, brought it to dealer and they hooked the computer up and did compression check, all checked out good. It has been pretty hot and humid here lately as well.

  3. #13

    Join Date
    Jul 2020
    Location
    Dallas
    Posts
    8
    I am up to 6.9 hours...no change...7600 rpm equals 69 mph on the speedo. Except for a quick blip to 70 mph and 7700 rpms... thatís all it goes. Can someone confirm the 2020 RXT X 300 actually go to 8040 rpmís? My elevation is 250í above sea level, Air temp 80, water temp 70, weight 200 lbs.


  4. #14
    The RXT X 300 goes about 67mph from the factory as that is the setting for the gps limiter. That rpm will vary by watercraft. If you have a SCOM as well and are only running 7700rpm, well that's a problem.

  5. #15
    Quote Originally Posted by BMist371 View Post
    The RXT X 300 goes about 67mph from the factory as that is the setting for the gps limiter. That rpm will vary by watercraft. If you have a SCOM as well and are only running 7700rpm, well that's a problem.
    and that’s my situation with no solution found

  6. #16

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    627
    +1
    95
    I'd see if Riva will replace your scom. Could be the issue.

  7. #17

    Join Date
    Jun 2020
    Location
    Illinois
    Posts
    19
    Quote Originally Posted by skylolow View Post
    I'd see if Riva will replace your scom. Could be the issue.
    I called to get their opinion and they said it has nothing to do with rpms. The guy I talked to wasn’t very friendly. I unplugged the scom and still not getting full rpms. When the scom is plugged in it starts in sport as it should and i got 72/73 and held it downstream on glass water so it seems to be working. Just don’t know where the rest of my rpms are.

  8. #18

    Join Date
    Jun 2020
    Location
    Illinois
    Posts
    19
    Quote Originally Posted by MikeR397 View Post
    and that’s my situation with no solution found
    Pretty annoying when we spend this type of coin on a new ski and it doesn’t perform as it should. It almost seems electrical or propulsion related. I get proper rpms under no load but can’t break 7700 on the water.

  9. #19
    Quote Originally Posted by skylolow View Post
    I'd see if Riva will replace your scom. Could be the issue.
    I did have riva replace my scom last year. Didn’t help with this issue

  10. +1 by:


  11. #20
    Throttle body not opening completely maybe?

Page 2 of 6 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Video: 2020 Sea-Doo GTX RXT-X 300 vs. 2020 RXP-X 300 Comparison
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 05-06-2020, 12:10 AM
  2. Pulling stickers off RXT-X 300
    By Sandman_73 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-13-2016, 11:33 AM
  3. RXT only turning 7600 RPM and 54 MPH GPS??
    By richte18 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-29-2014, 10:08 PM
  4. 2011 300 LX only pulling 7400 RPM ?? any ideas ??
    By nz253 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 02-23-2014, 07:35 AM
  5. rxt x used to make 8000 rpm now 7600 whats wrong
    By tallybrick in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-05-2010, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •