Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 72
  1. #21
    Have you removed the carbs and disassembled? Lets start with the basics those o-rings rarely cause an issue and just adding an electric fuel pump isn't going to replace them.

    A member on pwctoday did fit an electric pump, i just dont see the need.

  2. #22
    The carbs are off but that is all. Haven't had it in me to mess with it. Maybe this weekend.

  3. #23
    You wont be touching any of those o-rings during cleaning

  4. #24
    It has more issues than my ex-wife

  5. +1 by:


  6. #25
    Sounds like the carbs are the cause of your multiple failures

  7. #26
    Yeah thats what I was thinking. Or something to do with fuel/oil. It had 6+ hours on it. Ran great and I just rebuilt the damn pump. The first time it was #1 and it was a perfect storm. I didnt know what to check. # 2 oil line came off and it hit a big wake. When it landed I think the oil pump cable jumped off because the nimbrod that put it on had it on wrong. It was angled to the outside of the guide had just needed a nudge to jump off. Now its #3.
    Last edited by Lowryder898; 07-07-2020 at 08:44 AM.

  8. #27
    If oil pump cable comes off it defaults to full flow

  9. #28
    Really. Thats interesting. Strange as well. This was in SeptemberClick image for larger version. 

Name:	1013191623.jpg 
Views:	22 
Size:	53.4 KB 
ID:	464119

  10. #29
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,649
    +1
    749
    Looks like a saltwater 'Ski.

    Don't give up!


  11. #30
    Im trying not to. I think they both were. I bought them as a pair. The stxr and the VX. Fort Lauderdale. I have clean up alot on the stxr that could be. The lower case not so much.

Page 3 of 8 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Piston & cylinder issue
    By hubsta in forum MSX/Matrix
    Replies: 5
    Last Post: 09-09-2016, 08:34 AM
  2. FS advant ecu. stxr1200 + ultra 150
    By stxracer86 in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 09-18-2010, 03:26 AM
  3. Piston Issue and More
    By Wiweeds in forum Polaris Open Discussion
    Replies: 10
    Last Post: 07-08-2010, 07:35 PM
  4. 03 kawasaki stxr1200 bleeding oil pump
    By 2004 xlt1200 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-31-2009, 02:20 PM
  5. stxr1200 or xlt 1200
    By sleblanc in forum Polaris Open Discussion
    Replies: 1
    Last Post: 03-03-2007, 01:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •