Results 1 to 2 of 2
  1. #1

    Polaris Virage MFI does not respond to buttons or engine start

    Hi
    I have a 2000 Polaris Virage. Mfi seems to not wake up. It says the time and unlocked. But will not respond to pushing the buttons or when the ski is running

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,189
    +1
    2,134
    Welcome.

    Unplug the connector on the back side. Wait ten minues, then reconnect. See if it now works.

    More useful info here.

    http://polarispwcknowledge.shorturl....t-things-to-do


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1200 Polaris MFI start up issue
    By Duckgravy in forum Open Discussion
    Replies: 2
    Last Post: 11-12-2019, 10:12 AM
  2. Replies: 3
    Last Post: 01-15-2015, 11:57 PM
  3. Polaris Virage i 2002 MFI
    By Rowdy72 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 12-27-2013, 05:01 PM
  4. 2001 Polaris Virage {mfi or mfd}
    By catfish in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-15-2013, 10:17 PM
  5. WTB - Parts Polaris Genesis or Virage MFI display pieces
    By K447 in forum Polaris Classifieds
    Replies: 4
    Last Post: 11-26-2013, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •