Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    STX-15F Oil Leak- Not Burning Oil

    Hey everyone,

    First post on the forum. I was recently gifted a 2013 Ultra 300 and a 2005 STX-15F. The Ultra 300 runs perfect. The STX-15F supposedly burned a little bit of oil.

    Well I finally had some time to get the 15F running. Looking in the bottom of hull, I saw quite a bit of oil floating around. I grabbed my oil pump, sucked the oil out, then filled with soapy water and then drained and pressure washed the inside of the hull. Everything was fairly clean. I figured since the ski "burned a little oil" someone had simply spilled oil and that was what I was seeing. Then I drained the engine oil. It had a little milkyness and was fairly low. Pumping the oil out of the crank case yielded me about 1 1/2 quarts. I pulled the filter, found more oil around the base but the oil inside the filter wasn't milky at all. Anyways, I filled the engine up with 5 quarts of oil, checked the dip stick, everything looked good. I get the hose plugged in and start the ski. It doesn't run great but it runs (fuel pump is corroded pretty badly). After running for a few minutes, I shut it down and proceed to check the oil level again. Now the dipstick shows the oil severely low again. I look into the hull again and all the new oil I just poured into the engine leaked out in about 5 minutes of run time. Now the hull is full of oil again.

    Long story short, anyone experience this? My first thought is to pull the oil cooler and oil cooler lines and see if there is any leak there. But didn't know if there is another place I should start first. Thanks everyone.

  2. #2
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    548
    +1
    22
    Flashlight and a mirror is your friend here.

  3. #3
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    508
    +1
    26
    Check the oil hoses under the pto cover. Also check the dipstick fitting in the oil pan. Bit of those spots are the lowest on the engine. You can move your way up from there

  4. #4

    Join Date
    Dec 2018
    Location
    Knoxville, TN
    Posts
    101
    +1
    14
    The good news is that the leak is so bad it should be easy to find.

  5. +1 by:


  6. #5
    Guys, so sorry I didn’t respond. I was not getting reply notifications so I just assumed no one responded. I started tearing into it. Removed intake manifold. Found a broken water hose. Removed the pto cover and checked the hoses. I also checked the dip stick tube. Nothing feels loose but damn is it an absolutely mess in there. With the way it is right now, I don’t know how I’m going to feel for a leak. Gonna have to do cleaning first. Everything I touch has oil on it. I even took the ski to the car wash a pressure washed and soaped the crap out of the inside of the hull but I guess I didn’t do a very good job. Checking the oil level today, it’s bone dry so that tells me the leak is at the bottom of the engine. Just not sure where.


  7. #6
    After digging around more, I found this. Any idea what this could be?






  8. #7
    Update: I removed all of the external components connected to the engine, de-greased the entire engine and hull thoroughly. Started feeling and looking with a flashlight and a mirror. Oil hoses looked good, no oil under oil cooler, no oil under dipstick tube. Felt everywhere that I could reach and nothing felt cracked or broken. I then decided to level the jetski and pour a quart of oil into the engine. I wrapped my arms around the engine, placing my left hand directly under the dip stick tube and right directly under the oil cooler hoses. No leaks. But after about 60 seconds of sitting there, my right hand started to become covered in oil. Except, it wasn't coming from the oil hoses or fittings. It was coming directly from the oil pan. I could not fit my hands any further underneath the oil pan so I knew my only option was to pull the engine.

    Pulled the engine and found the problem. A battery post bolt looks to have been lost and was pinned underneath the oil pan. Over time, this bolt vibrated and ground a hole through the oil pan which caused the leak. So last night, I ordered a new oil pan and gasket, oil cooler o-ring, intake and exhaust manifold gaskets. I should have the oil leak fixed. The next hurdle is going to be finding why the existing oil was slightly milky.




  9. #8

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,130
    +1
    181
    Good investigative work! A long time GH member (nmpeter) posted this failure he found on a customer's ski one time. I can't figure out what that rubber bushing is but that bolt looks like the ones used to attach the flame arrester to the hull.


  10. #9
    Dang! what bad luck. And apparently it happened to one other unlucky owner. Good job on finding it.


  11. #10
    New parts came in yesterday so I put the engine on my engine stand, flipped it over, and removed the oil pan and oil cooler. The hole in the oil pan was almost 1/4" in diameter. Way larger than I could see from the outside. The oil cooler was a complete mess. It doesn't appear to be leaking and o-rings were in good shape but the raw water side had some serious lime build up. This ski was only ridden in fresh water at a central Texas lake. Regardless, everything cleaned up nicely so I put everything back together. I ended the evening with cleaning the engine. Lots of layered gunk and grime. As I came around to the front side of the engine, I noticed some cracks in the block. Are these cracks detrimental? Does this mean new engine?






Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 STX 15f burning oil/running rough
    By kevin11mic in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 05-19-2020, 06:35 PM
  2. Replies: 7
    Last Post: 06-27-2017, 03:58 PM
  3. Kawasaki 1100 STX - burning oil
    By Boldfist1100STX in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 06-10-2015, 07:20 PM
  4. Replies: 4
    Last Post: 04-09-2011, 01:34 AM
  5. oil leak----help ! stx-15
    By blades33 in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 11-17-2010, 06:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •