Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 71
  1. #61
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,988
    +1
    2,186
    most likely now that my long term storage has finally come on line I have the answer on your stator issue

    Using bolts that are too long when running the flywheel puller will do that exact type of damage if the flywheel turns while the long bolts are in there. Lots of gotchas in the world of polaris

    Having the correct bolt length is key, and a sturdy puller is a must.

    good ugga ugga helps loads

  2. #62
    Gotens22's Avatar
    Join Date
    Jun 2020
    Location
    Sacramento, Ca
    Posts
    37
    The flywheel was not turning, the puller was twisting. The impact gun caused no "twisting" force due to its impact nature.

  3. #63
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,988
    +1
    2,186
    I was insinuating that the stator was damaged by the PO removing or attempting to remove the flywheel and that damage finally caused stator failure

    Fact that the flywheel was quite troublesome to remove supports the “they tried to get it off” assumption

  4. #64
    Gotens22's Avatar
    Join Date
    Jun 2020
    Location
    Sacramento, Ca
    Posts
    37
    I have seen a lot of posts on the MFD for the LCD but what about the speedo? My LCD works fine but my speedo was stuck a 80 mph with the ski on or off. I unplugged the display and it stays at 80. The needle does not cycle on the MFD wake up like the other one. Is there a repair for this or am I just stuck with it as is because $200 for another MFD is painful

  5. #65
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,532
    +1
    2,169
    Quote Originally Posted by Gotens22 View Post
    I have seen a lot of posts on the MFD for the LCD but what about the speedo? My LCD works fine but my speedo was stuck a 80 mph with the ski on or off. I unplugged the display and it stays at 80. The needle does not cycle on the MFD wake up like the other one.

    Is there a repair for this or am I just stuck with it as is because $200 for another MFD is painful
    The MFI used on Virage and Genesis is generally not repaired. Meaning that when they fail, it is replaced rather than repaired.

    There is a digital speed display mode, press the Display button.

    Years ago on here myself and a few other members posted what is inside the MFI display. If you want to cut it open and attempt repair, the info in those threads might be helpful.

    http://greenhulk.net/forums/showthre...=1#post1180188

    http://greenhulk.net/forums/showthre...=1#post2288717

    http://greenhulk.net/forums/showthre...=1#post2933253

  6. #66
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,297
    +1
    137
    Quote Originally Posted by Gotens22 View Post
    I have seen a lot of posts on the MFD for the LCD but what about the speedo? My LCD works fine but my speedo was stuck a 80 mph with the ski on or off. I unplugged the display and it stays at 80. The needle does not cycle on the MFD wake up like the other one. Is there a repair for this or am I just stuck with it as is because $200 for another MFD is painful
    If you don't have any success repairing yours, I have an extra I'll sell for $150.

  7. #67
    Gotens22's Avatar
    Join Date
    Jun 2020
    Location
    Sacramento, Ca
    Posts
    37
    I didn't know there was a digital readout for MPH and thats good enough for me. Actually I might be a glutton for dispair... i randomally found another 2002 red virage I for sale in my area for $1500 with trailer (not running). So you know if I cannot figure it out at this point ill be asking you guys!


  8. #68
    Gotens22's Avatar
    Join Date
    Jun 2020
    Location
    Sacramento, Ca
    Posts
    37
    Bad EMM on the 3rd ski I just bought, Easy enough... off to lakeside

  9. #69
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,102
    +1
    255
    Quote Originally Posted by Gotens22 View Post
    Bad EMM on the 3rd ski I just bought, Easy enough... off to lakeside
    Thanks for the heads up, I'll have my catcher's mitt out

  10. #70

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    112
    +1
    8
    Quote Originally Posted by Gotens22 View Post
    I have seen a lot of posts on the MFD for the LCD but what about the speedo? My LCD works fine but my speedo was stuck a 80 mph with the ski on or off. I unplugged the display and it stays at 80. The needle does not cycle on the MFD wake up like the other one. Is there a repair for this or am I just stuck with it as is because $200 for another MFD is painful
    I think that this is going to be a winter project for me. The speedo was stuck at 80 but is now working again . . . and the black needle cover popped off. Soooo I will be making that a winter project.

    I am willing to bet it is a capacitor in the motor driver circuit.

Page 7 of 8 FirstFirst ... 5678 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris virage i 800 wont start 2002
    By Sutho in forum Polaris PWC Performance
    Replies: 9
    Last Post: 04-09-2017, 02:46 PM
  2. i need some help guys...2002 polaris 800di virage..help
    By phazek in forum Polaris Open Discussion
    Replies: 21
    Last Post: 03-08-2013, 04:00 PM
  3. 2002 polaris 800di virage help..help..help
    By phazek in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 02-03-2013, 08:41 PM
  4. 2002 Polaris Virage 800 DI, wont start all time
    By rabiddawg in forum Polaris Tech Tips and Info
    Replies: 2
    Last Post: 08-08-2012, 02:59 PM
  5. 2002 polaris virage i wont start
    By BLOWN HOWARD in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-01-2010, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •