Page 1 of 3 123 LastLast
Results 1 to 10 of 23
  1. #1
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2

    Stx di battery warning light

    Hello, I bought my 2000 Kawasaki stx 1100 di last year finally am able to ride it and have fun with it. As I was riding it yesterday the battery warning light came on flashing and stayed on almost the whole time I was out there but didn't notice anything different, it stayed on and ran great. The light and warning will go away usually at WOT but will definitely come back on later in the ride at the no wake zone I have to go throuh. Does anyone know about this I have another stator in the garage that I can swap if needed. I read a little online about testing the resistance of the stator but would like more info on that, also read it could be the magnets on the flywheel but again I would like some help from someone who has dealt with this before ripping it open again.

    Thank you

  2. #2

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6
    Maybe it could just be the battery? How old is it? Do you have a volt meter to see what it reads? Do you have a charger you could put on the battery to see if it does better on a charger than it does running in the ski?
    If volts are low and it doesn’t do any better on the charger, it’s prolly time for a new battery.
    If volts are low and it does much better on the charger, battery is prolly OK and proceed with ski troubleshooting.
    A good 12 volt battery should read slightly higher than 12.0. If it reads anything less after charging, even 11.9 it’s weak.

  3. #3
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2
    Great info, I bought this battery off eBay when I first bought the ski last year and never charged it. So it probably is the battery. I have a decent multimeter I can check the voltage on the battery and I will throw it on the charger for a few hours And check again.

    I always thought the stator should keep the battery at about 14 volts while running. This is why I thought maybe stator related but will definitely check out that battery first, and will lyk.

  4. #4
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2
    Quick update, not sure what this means but I checked the battery with it just sitting in the water and it was 12.18volts. I started the ski checked the voltage at the battery while running and it was 11.98volts. this makes me think the charging source is not charging the battery. Is this correct? I don't know much about this kind of stuff. Any help would be greatly appreciated

  5. #5
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,070
    +1
    249
    The EMM has the charging circuit in it (ultimately powered by the stator). There is a common weak point in the charging circuit. I (via Lakeside Tech) can repair your EMM.

  6. +1 by:


  7. #6
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2
    I don't think it is the emm there is no other issues with the ski just sometimes the battery light come on then goes off. Rpms go up past 7000 and it runs mint is there a test I can do on the stator there are no other warning lights coming on.

  8. #7
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,070
    +1
    249
    If the battery is not charging, either the EMM or the stator is bad. But a bad stator would likely result in hard starting.

  9. #8
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2
    I will test the stator first I would rather not spend the money for the emm. I also have another stator I can swap and see if there is a difference. Kinda funny you say hard starting because I was riding earlier and stopped to take a swim, when I went to start it up it took a few tries..

  10. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,933
    +1
    2,175
    you're wasting your time and effort. Without 13.5 v at the battery when the engine is running the problem is most likely the emm. you can check the stator, but problems there typically result in a no start condition. as if the stator isn't putting out, the dc-dc converter can't make enough voltage to fire the injectors

    you can't go wrong sending your emm to lakeside.

    of course your battery is also highly suspect but a bad battery will overheat the regulator in short order and smoke it. Not to mention the ski is 20 years old and the emm components are known to fail just from age

    you can grind if you want, but in the end, the emm needs to be checked. those ski are super reliable. When I spring service a winterized ski, they typically fire at the very first press of the starter.

    if you read up on the functionality of the Fitch injection system once the stator output a/c output reaches its setpoint while cranking the emm directs the 12v output to the dc-dc converter ( internal to the emm) and that provides the 45 volts to the injectors for running. during cranking it provides 26 volts, just enough to get the engine started.

    the only other possible thing to check is the connector at the emm itself. you'll need a 4mm allen wrench to remove it. The screw is right in the middle of it eyeball (only) the pins on the smaller connector, that's the one that provides charging voltage. Be careful working around the emm, that bracket is so sharp it can ruin your day. Don't ask me how I know that. I don't rightly recall but I think both connectors use the screw, maybe the small one uses just some clips. The bigger one uses the screw for sure

    whatever you do avoid jump starting the ski during diagnostics. the emm doesn't take well to spiking.

    you can find some interesting stuff on the emm and its various failure modes here.
    [ http://polarispwcknowledge.shorturl....t-things-to-do ]
    Last edited by K447; 06-06-2020 at 10:24 AM. Reason: Added link

  11. +1 by:


  12. #10
    Kawachris's Avatar
    Join Date
    May 2020
    Location
    New Hampshire
    Posts
    44
    +1
    2
    Great, this is the info I am looking for on this website. I recently had the emm out of the ski so maybe I didn't tighten the 4mm screw all the way. Like I said it has been running mint usually starts right up.(until I removed the emm and reinstalled it)

    I will check everything out and at the end of the season I will totally call up lakeside to check out the emm. I would really like things to be correct especially being out on the lake.

    I just got the ski running not long ago and do not know much about it. Luckily I haven't had to deal with the emm yet, when I got it I found a broken ground wire on the coil cluster . I fixed that and it fired right up. The reason I had the emm out was because I bought another stx di, the guy I got it from said the emm was bad. I put the emm from the original ski in the "parts ski" and that fired right up.

    I will check out the emm connections and will update this page. Idk if this helps but the battery light comes on when I first start it, once I get it up to cruising speed the light will shut off. The light stays off until I go back down to an idle.

    Thanks for all the help I certainly need it, newbie here.n


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 260X Shuts Off/Battery Warning Light
    By microracer24 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-06-2018, 05:29 AM
  2. Warning Light, Error code 163, Battery Replaced
    By Steviedeviant in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 05-29-2018, 12:36 PM
  3. Replies: 0
    Last Post: 06-17-2016, 11:48 AM
  4. Kawasaki STX-15F 2008 fuel warning light on
    By mcmurtrey in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-03-2011, 11:33 AM
  5. Battery Warning Light Keeps Coming On When Ski Started
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-13-2008, 05:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •