Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1

    300x Impeller + wedge install. Any tips?

    What's up guys? I just ordered a Solas 14/21 and 2deg wedge from the online store. I've checked most of the threads I could by searching but figured I would ask too. Any tips or suggestions for the install? I have e a shop manual and everything seems pretty simple. I'm not concerned or worried about the job itself, just curious of anyone has any tips that arent in the manual. Or of theres anything else I should do while I'm in there. I've had mu seadoo one apart countless times, it's just the 1st time with the Kawasaki. Any good tips/tricks? Anything I should do while its apart? Things I should seal good while I'm at it? Etc?

    Side note. It's a 2013 300x with approx 40 hours on it. All stock with free air mods and limiter removed. I'm currently seeing 79xx rpms with the occasional 8000 and a consistent 70.5 gps on a full tank. Anyone want to venture a guess on what it does after the impeller and wedge?

  2. #2
    My guess = 71.5

  3. #3
    any update on your #s ?

  4. #4
    Sorry no update yet. The wedge was out of stock so I’m still waiting on it. I did get the impeller put in. It seems to hook up and pull a little better and rpms did drop a little but I’m unsure if speed has increased as the temps have gone way up here. I can for sure say speed has not lowered. 69.x mph about 2-3 weeks ago pre impeller and last time I was out I still saw 69.x mph with it. But there has been an air temp increase of about 20deg and the water temp has risen too. I’m going out a bit later today and will gps it and see what it does, but it’s 90 and humid so I’m not expecting anything great.

  5. #5
    stock impeller is hard to beat,,, plus i found them way more durable than the 2 solas props i had. solas are more cavitation and leading edge damage prone. Most of the bolt on crap does very little for the ultra platform.

  6. #6
    Agreed, there isn’t much gain with bolt on stuff for these at all. Just got back in from another ride. 2 riders(300ish lbs total) and a full tank, temp is low 90s with 60% humidity. 69.5 on the garmin at 7750/7800rpms. That’s 1 mph better than my last outing in similar/same weather with only 1 rider on the stock impeller at 8050/8100. The stock impeller was cavitating a little on acceleration but this one isn’t. Overall I’ll take it. Small gain but no more cav. Once the wedge shows up I’ll put it in and see what happens, I’m not expecting much.

  7. #7
    cool temps and cooler water always = better numbers. higher heat, humidity and water temps along with heat soak really take a bite out of top speed runs...
    Last edited by Chris288; 06-22-2020 at 06:05 PM.

  8. +1 by:


  9. #8
    In the spirit of not leaving a thread with out a conclusion, my wedge came in a couple of weeks ago and I finally got a solo
    run on it. I didn’t write down temp and humidity and all but it was in the high 80s and not terribly humid, ski went 72.2 on gps. If it’s important to people I’ll get vid or pics, misty just replying to not leave someone who is searching the forum with out a conclusion to the thread


  10. #9
    Quote Originally Posted by Adam4pt6 View Post
    In the spirit of not leaving a thread with out a conclusion, my wedge came in a couple of weeks ago and I finally got a solo
    run on it. I didn’t write down temp and humidity and all but it was in the high 80s and not terribly humid, ski went 72.2 on gps. If it’s important to people I’ll get vid or pics, misty just replying to not leave someone who is searching the forum with out a conclusion to the thread
    Nice for just impeller and pump wedge.

  11. #10
    I can’t complain. This ski is about to become my wife’s and I’m switching to a GP1800 so this is probably it as far as mods go on the 300x. I got that speed after riding for a couple of hours with a half of a tank left. When the temp starts to cool back off I’ll probably try to make another pass on it just to see if it does any better. But for now the kawi is done getting new parts, maybe some sponsons to get some handling back but that’s probably it.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 300X tuning tips
    By Tillbuilt in forum Flyboard
    Replies: 0
    Last Post: 06-19-2014, 05:59 PM
  2. Bough Used 2011 300x Need some tips
    By azsuptt in forum Kawasaki Open Discussion
    Replies: 13
    Last Post: 05-20-2014, 12:08 AM
  3. Newb with 300x tips please!
    By octobon in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 03-19-2013, 09:19 AM
  4. Tips on 300X Exhaust Filter
    By meangreenman in forum Kawasaki Tech Tips and Info
    Replies: 4
    Last Post: 07-25-2012, 11:11 PM
  5. RR IC install tips???
    By Water4fire in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-24-2006, 11:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •