Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    no codes just says Maint and End when you go to look at the codes.

  2. #12
    Compression is 173-175 per cylinder. So I say the engine is solid. Its the MAINT display that pops up when I put the DESS on that has my attention. Since its not giving a fault code I wonder if a sensor is failing or is slightly out of range. This makes my think of EGT, or the TPS or the other on on the intake side that slips my mind. I did unplug my EGT sensor and the ski got made with an alarm.

    I will ask does this ski model have any built in timers that will trigger so you take it to the shop to clear the MAINT message? If that's the case I maybe I have a internal exhaust leak in the ski and its choking off the engine and the MAINT is nothing since I have no fault codes.

  3. #13
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,189
    +1
    824
    Bill, get an Owners Manual and a Shop Manual, www.brpmanuals.com.

    The MAINT display is only a service reminder, typically every 100 hours. It will blink every startup for 10 seconds. You can reset it with a Candoo Pro setup or have a stealership do it with BUDS software.

    Since you have replaced plugs and coils, I would pull the fuel pump out of the tank and check the filters on the bottom. The fuel pump itself may be going out also. Next, send injectors out for cleaning.

  4. #14
    I am heading down that road. Yes the injectors are on my mind too.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 VXS runs rough/missing at idle (non throttle) only, "spiky rpm's"
    By tgarris in forum Yamaha PWC Performance (4-stroke)
    Replies: 30
    Last Post: 07-24-2017, 10:00 AM
  2. TPS - Idle issue and rpm loss
    By Pwgsx in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-10-2013, 01:37 PM
  3. Ultra 250X Problems - Rough Idle, will not go past 25MPH, runs rough
    By troye in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 10-09-2012, 10:47 AM
  4. 2002 GTX RFI rough idle, bog at 2000-2500 rpm with new SBT motor
    By fnietoii in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-14-2012, 10:20 AM
  5. Low Rpm and Rough Idle
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 10-05-2006, 09:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •