Results 1 to 5 of 5
  1. #1
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    981
    +1
    30

    No Connectivit;y to ski 2004 185 GTX

    When I post the ski with key, all I get is "Seadoo" word on the display. No beeps. Will not connect to Candoo. Beeper has always worked. No start.

    History:
    I needed to make a key for a different ECU2003 GTX (155 NA), but didnt have a ski for that ECU, so I pulled the ecu connector out off my 2004 185 LImited and made 2 keys to the the 2003 ECU 155. All went fine. Until I plugged my ECU connectors back into the 2004 185. (key out) Now all I get is "Seadoo" on display. I must confess, I didn't start the ski before I started the above procedure, so none of the above may have any merit.


    What I have tried so far:
    Checked all fuses. - Good
    All pins look good, but cleaned them and put contact grease on them.
    Swapped the ecu to a another 185. It worked. So good ECU.
    Swapped the Mpem over to another 185, It worked. So good MPEM.

    Put known good ECU into the 2004. Did not help.
    Put known good Mpem into 2004. Did not help.
    Tried different keys. Did not help.

    Seems like ECU is not getting power maybe. Any ideas ?

  2. #2
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,054
    +1
    425
    Are the grounds good?

  3. #3
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    981
    +1
    30
    Quote Originally Posted by moparguy View Post
    Are the grounds good?
    Not yet. Since the word”Seadoo” comes on display I would think I had grounds.

    anyone know what pin powers ecu?

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,934
    +1
    2,176
    check the ecu connector for a pin pushed in.

    that sucks

  5. #5
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    981
    +1
    30
    Unknown fix. Do I took top off of ECU wiring Block "B" and started probing for the 12v circuit. Ski came back to life. Must have a loose pin somewhere. I am not confident it is fixed, but all works as it should now. Will see if problem returns.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 gtx 185 sc what direction to go
    By danm624 in forum 4-Tec Performance
    Replies: 8
    Last Post: 12-17-2015, 08:20 PM
  2. FS 2- 2004 seadoo gtx 185
    By keith neff in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 05-11-2014, 07:55 AM
  3. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-09-2008, 09:14 PM
  4. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-26-2008, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •