Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    x2ryder's Avatar
    Join Date
    Mar 2007
    Location
    Moline, Illinois
    Posts
    457
    +1
    1

    Ultra 150 oil line

    Took carbs off to clean them. Oil lines are tygon but 9 years old. I noticed the rear oil line is a lighter color then the other 2? Also rear carb has oil init when I took it apart? Anyone have any idea why the rear line is lighter in color?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	F1990D1A-A54A-4027-BBB9-EB259D18E884.jpg 
Views:	19 
Size:	60.9 KB 
ID:	462269   Click image for larger version. 

Name:	BDA2AEAF-D8F9-44F1-9872-CF0E8630FB8C.jpg 
Views:	22 
Size:	90.6 KB 
ID:	462270  

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,478
    +1
    732
    The pop-off valve on that carb is probably seeping, allowing hydrostatic pressure from the oil tank to flood the carb. You might try cleaning it with solvent and applying light pressure to both sides of it to break the ball loose. The pop-off valve should open at 4 - 5 PSI.

    Looks like somebody ran out of green hose and switched to yellow.

  3. #3
    x2ryder's Avatar
    Join Date
    Mar 2007
    Location
    Moline, Illinois
    Posts
    457
    +1
    1
    Quote Originally Posted by steve45 View Post
    The pop-off valve on that carb is probably seeping, allowing hydrostatic pressure from the oil tank to flood the carb. You might try cleaning it with solvent and applying light pressure to both sides of it to break the ball loose. The pop-off valve should open at 4 - 5 PSI.

    Looks like somebody ran out of green hose and switched to yellow.
    Thanks I will try it. No those were all yellow at one point.

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,478
    +1
    732
    Does it have any oil in it?

  5. #5
    Quote Originally Posted by steve45 View Post
    Does it have any oil in it?
    It does look like the line is empty in that photo.

  6. #6
    x2ryder's Avatar
    Join Date
    Mar 2007
    Location
    Moline, Illinois
    Posts
    457
    +1
    1
    Quote Originally Posted by beekermartin View Post
    It does look like the line is empty in that photo.
    yeah it had a little oil in it.

  7. #7
    Quote Originally Posted by x2ryder View Post
    yeah it had a little oil in it.
    Once you get the problem solved you will need to prime that line before running the motor. Or you can run premix in the tank until the line is fully primed. It takes the pump a long time to prime that line. If you run it empty like that you will probably have significant damage on that cylinder.

  8. #8

    Join Date
    May 2015
    Location
    England
    Posts
    65
    +1
    1
    I've been fighting the same problem with my middle carb mate, full of oil all the time. I freed mine up by putting them in the ultra sonic cleaner multiple times and tapping it etc etc and I got it to hold 4 psi but it still weeps.
    There is an option to install in-line check valves by using Yamaha valves but I opted out of that.
    I just try and start mine on the hose regularly to clear them out and also someone on here told me to store the ski with the nose of the trailer as far down as possible which I was dubious about but seems to have really helped.


  9. #9
    Is it necessarily bad for oil to sit in the carbs? I checked all my check valves (ball and spring) when going through carbs but still kept finding oil in them.

  10. #10
    No its perfectly fine for it to sit in carbs

  11. +1 by:


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought used 1999 Ultra 150 oil line broke off
    By Slick Rick in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-22-2015, 01:35 PM
  2. ultra 150 oil line runs dry
    By drewski in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 07-28-2012, 01:22 PM
  3. 2001 ultra 150 manual and oil line replacement
    By ultra150rider in forum Open Discussion
    Replies: 0
    Last Post: 08-22-2010, 02:16 AM
  4. Ultra 150 oil line priming question
    By formula2fast in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-05-2010, 10:51 PM
  5. 2000 Ultra 150 Oil line replacement
    By jsun3701 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-18-2008, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •