Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6

    Ultra 150 overheat

    The mystery ski is running great so I’m staring a new thread on the other non-modded ski. Completely stock 1999 Ultra 150.

    It has triple pissers and all three piss but will overheat and go I to limp mode during WOT runs. Settle her down and she’s just fine. She cools off quickly and there’s no problem if not running WOT.

    What are your thoughts on where to start diagnosing?

  2. #2
    Have you felt the pipe where sensor is? Is it hot? Should be as cool as the cylinders. Have had trouble with bad sensors in the pass throwing a false over heat in the past.

  3. #3

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6
    I have an extra sensor. I tested both in a pot of water on the stove and they give the same readings which are very close to the book specs.

    Next suggestion?

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,506
    +1
    733
    At speed, the pissers should be spraying abundantly. And the water coming out should be about as hot as you can stand to put your hand in, perhaps warmer.

    Look for blockage in the hose from the jet pump to the water pipe (under the cylinders). Does this 'Ski have the 'Stinger Mod'? If so, the valve for that could be partially plugged or not adjusted correctly.

  5. +1 by:


  6. #5
    Stinger valve will not cause an over heat/limp mode.. only if the stinger gasket was installed incorrectly, the pipe would be very hot but cylinders cool

    I would run the ski and see where its cool and hot. Then remove cooling parts and inspect from there.

    I

  7. +1 by:


  8. #6
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    530
    +1
    22
    Where did you get the fittings that go in the head for the pisser kit? The I.D. on those have to be same as the stock ones

  9. #7

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6
    Quote Originally Posted by steve45 View Post
    At speed, the pissers should be spraying abundantly. And the water coming out should be about as hot as you can stand to put your hand in, perhaps warmer.

    Look for blockage in the hose from the jet pump to the water pipe (under the cylinders). Does this 'Ski have the 'Stinger Mod'? If so, the valve for that could be partially plugged or not adjusted correctly.
    I will remove the main line and inspect. No stinger mod on this ski.

  10. #8

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6
    Quote Originally Posted by TMiller View Post
    Where did you get the fittings that go in the head for the pisser kit? The I.D. on those have to be same as the stock ones
    Skiworx kit. They all appear to have the proper modifications.


  11. #9

    Join Date
    Mar 2020
    Location
    Lake Houston
    Posts
    51
    +1
    6
    Even though the two sensors tested the same I put the other one in to see if maybe I got a false positive with the pot of water method.
    I will run it and see what happens. I will also check temps with an infrared temp gun to see if I can find the hot spot(s).
    Thanks for the help!

  12. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,506
    +1
    733
    Quote Originally Posted by turboman412 View Post
    Stinger valve will not cause an over heat/limp mode.. only if the stinger gasket was installed incorrectly, the pipe would be very hot but cylinders cool

    I would run the ski and see where its cool and hot. Then remove cooling parts and inspect from there.

    I
    OK, the stinger mod cuts flow to the exhaust, but the water enters after the temp sensor.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 150 overheat
    By Meen95z in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-20-2018, 08:39 AM
  2. overheat light on my msx 150 not the suspects.
    By dragonxr600 in forum MSX/Matrix
    Replies: 16
    Last Post: 03-08-2017, 11:59 AM
  3. Fuel/Choke Knobs interchangable for 99' Ultra 150 to 00' Ultra 150
    By Meen95z in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-20-2015, 07:43 AM
  4. ultra lx overheat
    By bsmith45 in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 05-05-2008, 06:42 PM
  5. MSX 150 Overheat alarm ??
    By canuck in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-30-2006, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •