Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    2013 rxtx 260... Wtf

    2013 RXTX 260 with the following mods.

    IMUK, free flow exhaust pipe, work air intake, RIVA stage II tune, Solas 15/20R, stainless wear ring.

    I am only getting about 7800 RPM and 66 MPH. It seems to be running smooth, maybe a hesitation once in a while, but nothing that makes me
    worried at this point. But what the heck is going on? Should be much faster than that.

    Those speeds are from the onboard speedo... are they ever off by that much?

  2. #2
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    740
    +1
    68
    Did you ever went faster?

  3. #3
    This is the first time I have taken it for a ride. Just purchased it a couple of weeks ago.

  4. #4
    With those mods I would have expected to do better than 7800RPM and 65mph.

    does 7800 and 65mph correlate properly though? I mean does It seems that the machine is running OK, I am just not getting enough RPM to get the speed I want.

  5. #5
    raiderx72's Avatar
    Join Date
    Jul 2007
    Location
    Rocky Hill, CT
    Posts
    827
    +1
    89
    First dash mph is way off. Second I would check the supercharger slip.

  6. #6
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    740
    +1
    68
    Something is off.
    Due to the tune you should have enough rpm room above the stock limiter (8040)

    With worn wearring/prop you should make the rpm but not the speed. The 15/20 normally is one of the proper replacements for the stock prop.

    Check your IC for water leak into the charged air. The stock ones are famous for leaks and will rob you from rpm a lot.
    This could also clarify your (small) hesitation.

    Other cause could be fouled plugs or dirty fuel filters (2x) in your fuelpump assembly.

  7. #7
    Near wear ring and impeller, so that isn’t the issue. Intercooler is a newer RIVA and I don’t suspect it.

    just replaced the plugs and pumped out all the old gas.

    I am stumped. I figured I would run in the low 70s with 8100RPM

  8. #8
    raiderx72's Avatar
    Join Date
    Jul 2007
    Location
    Rocky Hill, CT
    Posts
    827
    +1
    89
    Check the supercharger slip.

  9. #9
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    4,013
    +1
    846
    Speed looks about right for the RPM, our Yamaha friend forgets we have GPS based speedometer. It's running 64-65 if compared to a handheld Garmin.

    - what elevation do you ride at?
    - air/water temperature?
    - how many hours since SC slip was checked/adjusted?
    - what's your target RPM?


  10. #10
    Quote Originally Posted by ptscon View Post
    Speed looks about right for the RPM, our Yamaha friend forgets we have GPS based speedometer. It's running 64-65 if compared to a handheld Garmin.

    - what elevation do you ride at?
    - air/water temperature?
    - how many hours since SC slip was checked/adjusted?
    - what's your target RPM?

    supercharger should only have about 10 hours on it. It was a new unit.
    riding at 1000ft elevation, cold water, not sure if exact temp, but it was chilly water!

    i definitely think I am missing some RPM. Don’t know how to adjust slip if the supercharger was slipping.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 rxtx 260 engine light flashing
    By Mattyaka in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-06-2019, 06:24 PM
  2. 2013 rxtx-as 260 best battery recommendation
    By lsubadboy1 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-15-2018, 05:06 AM
  3. FS - Parts Brand new 2013 rxtx 260 ecm
    By WICKEDSEADOO in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-16-2016, 12:28 PM
  4. SOLD 2013 rxtx 260
    By Water4fire in forum Sea Doo 4Tec Skis
    Replies: 10
    Last Post: 07-09-2016, 08:08 AM
  5. rxtx 260 2013 engine vibration
    By alali78 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-16-2016, 10:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •