Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    2013 ultra lx questions.

    A few questions. First I have replaced my pump bearings and seals. I am at 162 hrs. Machine runs great. But I noticed when I bought it it showed the peak speed someone had hit was 91kph (56 mph) but I have never been able to go over 88kph (54mph). I am atleast 100lbs lighter then the precious owner.
    Any ideas why itís not going to 91 anymore ?

    2. Before my pump bearing failed I noticed a vibration sound. Figured it was the pump bearings. Well I took it out for first time this past weekend and itís still there. Any common things that would cause this ?

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,511
    +1
    733
    I've got 2013 and 2010 Ultra LXs, I've never gotten either up to 56. I boat at about 2000' elevation and summer temps are typically about 100įF.

    You were reading the 'peak' speed the boat has seen. Could be that somebody had a pretty good tailwind pushing it through the water a bit faster than the engine could do by itself.

    Vibration is likely caused by trash in the pump.

  3. #3
    Quote Originally Posted by steve45 View Post
    I've got 2013 and 2010 Ultra LXs, I've never gotten either up to 56. I boat at about 2000' elevation and summer temps are typically about 100įF.

    You were reading the 'peak' speed the boat has seen. Could be that somebody had a pretty good tailwind pushing it through the water a bit faster than the engine could do by itself.

    Vibration is likely caused by trash in the pump.
    There is nothing in the pump. It did this before and after the new pump bearings.

  4. #4
    Quote Originally Posted by mike-ultra View Post
    There is nothing in the pump. It did this before and after the new pump bearings.
    Tail wind could be. We are at sea level and it was only 16c out. That is about 61f

  5. #5
    Ignore the speed.
    What is your RPM at WOT? Sustained.

    Between 7400 and 7600 on a stock ski is normal depending on elevation and air temp.

  6. #6
    Quote Originally Posted by prj View Post
    Ignore the speed.
    What is your RPM at WOT? Sustained.

    Between 7400 and 7600 on a stock ski is normal depending on elevation and air temp.
    Never noticed. I will look next time.

  7. #7
    Quote Originally Posted by mike-ultra View Post
    Never noticed. I will look next time.
    Make sure to cycle into the RPM display on the dash to see the exact number.
    The speed sensor (paddle wheel) is not very accurate, it's strongly affected by chop etc. If your pump is in good shape then it's usually better to go by RPM to gauge performance.

  8. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,511
    +1
    733
    Took both of my Ultra LXs out yesterday and couldn't get over 44 MPH with either one. It was very choppy and both tanks were completely full. I think the fuel level plays a big role in speed on that hull.

  9. #9
    Quote Originally Posted by steve45 View Post
    Took both of my Ultra LXs out yesterday and couldn't get over 44 MPH with either one. It was very choppy and both tanks were completely full. I think the fuel level plays a big role in speed on that hull.
    I can go 86kph on a full tank in chop

    Did you have your slow key ? MAybe your chop was bigger though.

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,511
    +1
    733
    No, SLO key is in the safe at home.


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 vxr questions
    By RPB in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 08-03-2017, 02:21 PM
  2. 2013 or 2013.5 Ultra 300X by HIN
    By kdaily in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 02-17-2017, 11:15 AM
  3. Sold 2013 FX SHO Bought 2 2013 FX HO's: Winterization Questions
    By stratosurfer in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 01-03-2017, 05:08 PM
  4. 2013 GTI limited 155 questions
    By hdultra in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-14-2014, 12:31 PM
  5. 2013 rxt260 questions ??
    By steach in forum Sea Doo Open Discussion
    Replies: 60
    Last Post: 11-02-2013, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •