Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    909
    +1
    89

    Ride plate thread insert broke

    Taking ride plate off to take pump out and the front left thread broke off about 1/4íí (pic attached) the screw still seems to have plenty of thread to grab but not Iím nervous about it and am wondering if it should replace the threads? I reinstalled to check how many threads and how right and itís plenty right etc. What do you all think?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DC78A7F4-79A7-4915-B255-6073CF94E8D5.jpg 
Views:	49 
Size:	47.9 KB 
ID:	461756   Click image for larger version. 

Name:	AF359BD0-96FF-4988-9BE3-F13320BFF7EB.jpg 
Views:	47 
Size:	31.0 KB 
ID:	461757  


  2. #2
    Rode most of last year with the same issue before replacing the bracket over the winter. Only thing I noticed was water was entering the hull from that bolt/hole. Not alot but was noticeable.

  3. #3
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    909
    +1
    89
    It wasn’t punctured. It’s just the sleeve part with the threads on it that broke 1/4” or so.

  4. #4
    Quote Originally Posted by DanSVHO View Post
    It wasn’t punctured. It’s just the sleeve part with the threads on it that broke 1/4” or so.
    Same with mine. It still leaked

  5. #5
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    909
    +1
    89
    must have had a crack on the bracket then. Did you do the repair?
    Quote Originally Posted by Z'mnypit View Post
    Same with mine. It still leaked

  6. #6
    Quote Originally Posted by DanSVHO View Post
    must have had a crack on the bracket then. Did you do the repair?
    No crack. It was leaking between the bracket and hull. I could fill the back with the water hose and look under and see it dripping down the bolt. Like I said it wasn't a huge amount but still noticeable. I bought a new bracket and popped the old one out then 3m 5200 the new one in.

  7. #7
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    909
    +1
    89
    ok so it wasn’t to hard to do?
    Quote Originally Posted by Z'mnypit View Post
    No crack. It was leaking between the bracket and hull. I could fill the back with the water hose and look under and see it dripping down the bolt. Like I said it wasn't a huge amount but still noticeable. I bought a new bracket and popped the old one out then 3m 5200 the new one in.

  8. #8
    Quote Originally Posted by DanSVHO View Post
    ok so it wasnít to hard to do?
    Its not hard, but it is awkward. I had one leaking a while ago and resealed both.

    Pulled the rear seat bracket to get better access, cleaned old glue and 5200'd the insert back in. Bolted up ride plate and let it cure.

  9. +1 by:


  10. #9
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    909
    +1
    89
    What are you guys putting on threads for a sealant if anything? Simple thread sealant or red lock tite?

  11. #10
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    715
    +1
    141
    Quote Originally Posted by DanSVHO View Post
    What are you guys putting on threads for a sealant if anything? Simple thread sealant or red lock tite?
    Just use silicone, it helps keep the bolts and the bracket from rusting together. Never had a intake, sponson or rideplate bolt come loose from using silicone
    Definitely donít use red loctite
    And donít use to much silicone, like putting a blob in the holes Iíve actually popped the top of the bracket clean off
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	140 
Size:	52.6 KB 
ID:	461925  

  12. +1 by:


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97-99 GP1200 Ride Plate Insert Upgrade
    By OsideBill in forum Yamaha Old School Skis
    Replies: 44
    Last Post: 04-25-2016, 05:06 PM
  2. Ride plate insert mod help
    By craigmedic in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-27-2009, 10:44 AM
  3. Replies: 7
    Last Post: 02-10-2009, 10:05 AM
  4. Ride plate insert kit
    By KirkF350 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-10-2007, 09:44 AM
  5. Ride Plate Insert Changing
    By spud in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 11-24-2006, 11:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •