Page 1 of 6 123 ... LastLast
Results 1 to 10 of 57
  1. #1
    youngDUMP's Avatar
    Join Date
    Jul 2015
    Location
    Oxford, Mississippi
    Posts
    247
    +1
    43

    GP1800 hull problems

    I changed my plugs for the first ride of the year and went to test today. Water intrusion like crazy. A good 6Ē in the hull after about 45 minutes of riding. Noticed after I pulled the ski and it heat draining water out of the bottom. Usually have about a cup of water maybe two down there, but when it didnít stop I pulled the seat and found water.

    Iím kicking myself in the ass because Iíve had the hull reinforcement plates at my house for over a year and havenít done it. I donít know what the damage is yet but Iím bringing it home to pull apart tomorrow if I can get time.

    Hereís a pic. Will post video
    Click image for larger version. 

Name:	IMG_0638.jpg 
Views:	198 
Size:	77.5 KB 
ID:	461718


  2. #2
    Pull the intake grate and check for cracks. Also check your cooling hoses for leaks.

  3. +1 by:


  4. #3
    youngDUMP's Avatar
    Join Date
    Jul 2015
    Location
    Oxford, Mississippi
    Posts
    247
    +1
    43
    Quote Originally Posted by eman2289 View Post
    Pull the intake grate and check for cracks. Also check your cooling hoses for leaks.
    Roger that. Will report back on that ASAP.

    Hereís the video



  5. #4
    Holy shit. I feel like there's something else going on because that has to be some big cracks to pour like that.

    Edit. Is that water pouring out of the transom plate? It's hard to tell in the video

  6. #5
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    717
    +1
    141
    Yikes, that does not look good! Are you stock?

  7. #6
    youngDUMP's Avatar
    Join Date
    Jul 2015
    Location
    Oxford, Mississippi
    Posts
    247
    +1
    43
    Intake, IMUK, free flow, and stage 1 plus tune. Everything else is stock.

  8. #7
    youngDUMP's Avatar
    Join Date
    Jul 2015
    Location
    Oxford, Mississippi
    Posts
    247
    +1
    43
    Ski was fine at the end of last year. Changed plugs today and rode lightly. 4 pulls WOT. Came unhooked once but I was playing in a slow circle just hopping back and forth. Not hard enough to even get myself wet. Iíll pull the grate and plate tomorrow when I get some free time at work and update.

  9. #8
    Quote Originally Posted by youngDUMP View Post
    Ski was fine at the end of last year. Changed plugs today and rode lightly. 4 pulls WOT. Came unhooked once but I was playing in a slow circle just hopping back and forth. Not hard enough to even get myself wet. Iíll pull the grate and plate tomorrow when I get some free time at work and update.
    Put it on the hose first and check your cooling lines. It's much easier to start there. Then pull the grate. But also fill the hull again and double check the transom plate. I know guys have had issues with them letting some water in at high speeds. Maybe something happened with yours

  10. +1 by:


  11. #9
    youngDUMP's Avatar
    Join Date
    Jul 2015
    Location
    Oxford, Mississippi
    Posts
    247
    +1
    43
    Thanks @eman2289 Iíll put it on the hose first.

  12. +1 by:


  13. #10
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    717
    +1
    141
    Quote Originally Posted by youngDUMP View Post
    Intake, IMUK, free flow, and stage 1 plus tune. Everything else is stock.
    I’m guessing your in the 79-80 mph range, so ya it’s very probable your intake has pulled away. It would be better if the sealant let go around your transom, but I’m betting it’s your intake. My brother is playing the same game 79-80 mph and hasn’t done the reinforcement either. Let us know what you find

Page 1 of 6 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gp1800 More air into hull
    By Slxrider in forum Yamaha PWC Performance (4-stroke)
    Replies: 16
    Last Post: 09-18-2019, 04:58 PM
  2. Just did the hull mod on my gp1800
    By 2017 fx svho in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 06-30-2019, 02:33 PM
  3. GP1800 Hull Mod
    By TrimmedOut15 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-25-2018, 08:04 PM
  4. anyone need gp1800 hull?
    By MrIgor in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-24-2018, 01:59 PM
  5. About to buy a GP1800. Any problems observed with these units? Disable neutral start?
    By dolphinride in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-02-2017, 05:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •