Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2

    Tps stuck at 3000rpm

    Hi I bought a used tps
    My old one I wasnít gettin full rpm

    The new used one I put on bolted up perfect
    Start it. Straight to 3000 and stays there will rev up with trottle but wonít fall to idle
    Is this tps bad also?


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,322
    +1
    2,144
    Measure the voltage output of the TPS.

    Meter probes on Black wire and center wire pin of the TPS connector. Use thin wires along the wires into back side of the Weatherpack connector.

    Idle voltage signal out of TPS should be roughly 0.350 to maybe 0.5xxx volts DC.

    Full throttle signal from TPS is over 4.0 volts. I forget the exact (specification) TPS voltage numbers but I have posted them elsewhere on here.

  3. #3
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2
    Quote Originally Posted by K447 View Post
    Measure the voltage output of the TPS.

    Meter probes on Black wire and center wire pin of the TPS connector. Use thin wires along the wires into back side of the Weatherpack connector.

    Idle voltage signal out of TPS should be roughly 0.350 to maybe 0.5xxx volts DC.

    Full throttle signal from TPS is over 4.0 volts. I forget the exact (specification) TPS voltage numbers but I have posted them elsewhere on here.
    Hi thanks for reply
    The tps did test right and was setup on the dw program
    But when I started boy was it reving 3000
    My old tps works perfect for idle but lost rpm 6650 max

    The sweep on the program didnít show any bad spots and worked great Iím surprised why it revs and stays at 3000

  4. #4
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,752
    +1
    1,560
    Quote Originally Posted by Msxslayer View Post
    Hi thanks for reply
    The tps did test right and was setup on the dw program
    But when I started boy was it reving 3000
    My old tps works perfect for idle but lost rpm 6650 max

    The sweep on the program didn’t show any bad spots and worked great I’m surprised why it revs and stays at 3000

    6650 is about right for top rpm. If you are down on rpm a little bit the tps isn’t where I’d be looking

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,322
    +1
    2,144
    Quote Originally Posted by Msxslayer View Post
    ...
    The tps did test right and was setup on the dw program
    ...

    The sweep on the program didnít show any bad spots and worked great Iím surprised why it revs and stays at 3000
    What are the actual signal voltages coming out of the TPS?

  6. #6
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2

    Tps stuck at 3000rpm

    Quote Originally Posted by K447 View Post
    What are the actual signal voltages coming out of the TPS?
    The max tps voltage is 3.6 on the old one

    Te new used one I got it was over 4v
    Lil under a v for idle
    But I have to manually turn the tps to get it to stop reving 3 thousand

  7. #7
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2
    Quote Originally Posted by Mr. GP1800 View Post
    6650 is about right for top rpm. If you are down on rpm a little bit the tps isnít where Iíd be looking
    Thought the rev limiter was 7200
    Iv got 7000 before but started dropping
    3.6v at max for tps. Thatís why I am working at the tps
    New topend and new prop
    Donít think anything g else is the problem

  8. #8
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,752
    +1
    1,560
    Quote Originally Posted by Msxslayer View Post
    Thought the rev limiter was 7200
    Iv got 7000 before but started dropping
    3.6v at max for tps. That’s why I am working at the tps
    New topend and new prop
    Don’t think anything g else is the problem
    These should run 6700ish at wot.

  9. #9
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2
    Quote Originally Posted by Mr. GP1800 View Post
    These should run 6700ish at wot.
    Ok thanks
    When I got it first I would easily hit 60mph ever time all the time

    Now Iím 51


    But this new used tps
    Is stuck at 3000 for some reason seems like this tps is bad

    But old tps can only get it to 3.6v need at least 4 v for wide open

  10. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,322
    +1
    2,144
    Quote Originally Posted by Msxslayer View Post
    The max tps voltage is 3.6 on the old one

    Te new used one I got it was over 4v
    Lil under a v for idle
    But I have to manually turn the tps to get it to stop reving 3 thousand
    Which model and year is this Ficht engine?
    TPS is pigtail or non-pigtail type?

    Exact voltages matter. A few tenths of a volt on the TPS output is a significant difference.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Genesis TPS and TPS test harness Good Price!
    By Chef in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-30-2014, 05:39 PM
  2. Replies: 26
    Last Post: 09-08-2011, 04:22 AM
  3. TPS Options for pigtail style TPS
    By bgaidan in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-14-2011, 11:21 AM
  4. vibration at 2500 3000rpm
    By MadSlow in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-23-2009, 07:30 PM
  5. GP1300R staying at 3000rpm
    By fullgaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-18-2009, 06:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •