Results 1 to 3 of 3
  1. #1
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    130
    +1
    2

    2018 RXPX -- Intermittent Limp Mode, then dies, wont start

    Last time I was out on my RXPX, it would throw a CEL when above 4,000 RPM. Go into limp mode and not exceed 3,000 RPM. I tried restarting it, nothing same result. I switched to learner key and it ran at learner key speeds without any issues. I kept switching back and forth with the keys and the problem went away. Ran great the whole day after this initial issue.

    Fast Forward this ride, started up fine tried to get on plane and it went back into limp mode. Tried to restart it, tried to get on plane. Ski just completely shut down. Would not crank after this. Solonoid clicking sound even when not trying to start it.

    START/STOP does not recognize touch
    Beeps if you pull reverse
    Clicking constantly from throttle body intake
    Battery 12.3V
    Reverse Grate stays in FWD position, will not cycle or stay in Neutral position

    Local shops backlogged 2 weeks. Got an idea that it might be the starter relay, can anyone confirm.

  2. #2
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,022
    +1
    417
    Quote Originally Posted by BallaRXP View Post
    Last time I was out on my RXPX, it would throw a CEL when above 4,000 RPM. Go into limp mode and not exceed 3,000 RPM. I tried restarting it, nothing same result. I switched to learner key and it ran at learner key speeds without any issues. I kept switching back and forth with the keys and the problem went away. Ran great the whole day after this initial issue.

    Fast Forward this ride, started up fine tried to get on plane and it went back into limp mode. Tried to restart it, tried to get on plane. Ski just completely shut down. Would not crank after this. Solonoid clicking sound even when not trying to start it.

    START/STOP does not recognize touch
    Beeps if you pull reverse
    Clicking constantly from throttle body intake
    Battery 12.3V
    Reverse Grate stays in FWD position, will not cycle or stay in Neutral position

    Local shops backlogged 2 weeks. Got an idea that it might be the starter relay, can anyone confirm.
    What codes is it throwing? Oil level? Stock or modded?


  3. #3
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    130
    +1
    2
    I don't have a scan tool to read codes
    Oil Level 50%
    Stock. Only have a SCOM and catch can.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2018 Seadoo RXPX 300 wont start just cranks
    By X-Rated in forum 4-Tec Performance
    Replies: 18
    Last Post: 04-18-2019, 10:36 PM
  2. Replies: 2
    Last Post: 03-11-2017, 08:05 PM
  3. Replies: 5
    Last Post: 10-18-2015, 03:33 PM
  4. Help, 2008 rxpx oil light coming on ang going into limp mode
    By Turboted in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-17-2013, 11:45 PM
  5. Intermittent Dash Problem & Limp Mode
    By 2weelz in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 09-05-2008, 11:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •