Results 1 to 10 of 10
  1. #1

    2018 Ultra LX speed sensor install from factory (correct or not)

    OK, with this work from home garbage, I'm trying to take up some time. I pulled my pump assembly from my 2018 Ultra LX, not because anything needed to be done, but I just wanted to learn how to do it and hit the splines with my Dupont grease. Anyways, when all was apart, I looked over at the metal bracket the speed sensor is attached to. There are three holes in that metal bracket and three threads going into the hull. There is only one screw in that bracket, in the middle screw hole. Did the factory miss the other two screws or is one what they intended? I tried looking at a parts diagram, but I couldn't ascertain what was going on. I do think it's only suppose to be one screw as I would think the parts diagram would show (3) screws needed in that area. I'm just a little leery about one screw in that location. Thoughts? Thanks guys and everyone stay safe.

    Also, anything else I should do while I'm in there? The ski has 15 hours on it.

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,285
    +1
    713
    I looked at the parts diagram, Meters section, and is shows (4) 92009-3703 screws.

    Oh, yea, glad to hear that you're working from home...

  3. #3
    LOL!!!! This IS work!!!! I'm going to order those screws and just install them with the appropriate sealant. Thanks for looking into that and getting back. Stay safe and stay clean!!

  4. #4
    Hey steve45, Those are not the correct part numbers. Those are for the 4 screws that connect the speed sensor itself to the base plate. I cannot for the life of me find that bracket on any parts diagram. It's for the bracket that holds the wire for the speed sensor as it goes thru the hull to the left of the pump, as you are looking at the pump. I have an email off to Kawasaki for direction. Thanks again brother. Appreciate you jumping in and helping out!

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,285
    +1
    713
    OK, so it just holds the wire? Perhaps one screw is enough. I'll have to look at mine.

    FYI, there are usually some parts that are not shown in the parts diagrams. I had an 1100 that was missing a plate in the fuel pump. Not shown in the parts diagram. I didn't even know it was missing until I disassembled another one. Very hard to find parts that aren't listed!

  6. #6
    Thanks man. I look forward to what you find on yours. Appreciate it!!

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,285
    +1
    713
    I finally got a chance to go look at my LX. It only has one screw on the bracket, even though there are 3 holes in it. It is also glued down pretty good with silicone adhesive. I don't think you have to worry about it coming off.

  8. #8
    Thank you "steve45". One less thing to stress over! I appreciate you taking the time out!

  9. #9
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,285
    +1
    713
    Update: I picked up a wrecked Ultra LX over the weekend (the one mentioned in another thread here). I've started parting it out and I want the jet pump & new style ride plate/speedo for my 2010 Ultra LX. I got the sensor out tonight, not at all what I expected. Here's a picture:



    Turns out that the threaded brass tube is glued in with the epoxy (or whatever) applied to the back. The stainless steel bracket is there to keep the brass tube from unscrewing when you tighten the plastic nut that secures the wires. Everything has a coating of silicone sealant to keep water out.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Speedometer Sensor Mount.jpg 
Views:	42 
Size:	304.3 KB 
ID:	459966  

  10. #10
    Ahhh, very interesting. Thanks steve45. Learn something new every day!


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2018 Ultra 310X water strainer install help
    By BH03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-27-2019, 10:16 AM
  2. 2018 310 Ultra x speed question
    By 250stxrider in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 07-30-2018, 10:10 PM
  3. Seadoo Speed sensor vs GPS for correct speed accuracy
    By Cathylongasta in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-30-2017, 03:20 PM
  4. Speedo sensor on Vx ride plate,how to correct it speed?
    By Teerayoot in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-26-2010, 12:38 PM
  5. STXR/ULTRA 150 factory triple pipe install vid by Jonny5
    By jonny5 in forum Videos & Pictures
    Replies: 2
    Last Post: 12-13-2009, 04:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •