Results 1 to 8 of 8
  1. #1
    millerro's Avatar
    Join Date
    Mar 2020
    Location
    Grand Rapids, MI
    Posts
    1

    Good Battery, No Power, No Crank, No....Anything

    The PWC is a 1993 Seadoo XP (White with Pink accents and Green Seats because that matters)

    I bought it used in spring of 2019 and it ran for a few months. Typical old PWC and it needed a few repairs.

    Since then I've replaced:
    -Starter
    -Starter Relay
    -Lanyard Switch
    -Battery
    -Spark Plugs
    -Rebuilt Carbs (Genuine Mikuni Rebuild Kit)

    After rebuilding the carbs it fired right up! Hooray!
    (https://drive.google.com/uc?view&id=...tmP-MkJReT1zU2)

    After that I left it in the garage waiting for a warm day to get out on the water. AND NOW IT WONT THINK ABOUT DOING ANYTHING!!!!
    It does not "click" or crank or make any sound of any kind. Someone please suggest something so I don't go insane.

    I've made sure the engine moves freely, I've double checked the battery, I've checked my connections inside the CDI, I've cleaned my battery terminals...

    Why is nothing happening??

  2. #2
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    745
    +1
    37
    Bad CDI?

  3. #3
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,169
    +1
    282
    Check all the cable connections from the battery, along with the cables ends. The cable ends may look OK but they'll get corroded on the inside and cause the exact same problem.

  4. #4

    Join Date
    Sep 2014
    Location
    Southern middle TN
    Posts
    526
    +1
    318
    on that model i do believe it has a solenoid. try crossing it with a sacrificial screwdriver (if you know how to do it safely) and see if it cranks over. if it does either the solenoid is bad or the power wire to it is not getting activated to tell it to fire off.


  5. #5
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,169
    +1
    282
    Quote Originally Posted by arctic388 View Post
    on that model i do believe it has a solenoid. try crossing it with a sacrificial screwdriver (if you know how to do it safely) and see if it cranks over. if it does either the solenoid is bad or the power wire to it is not getting activated to tell it to fire off.
    All models have a solenoid. And he's already replaced it.

  6. #6
    C. June's Avatar
    Join Date
    Apr 2020
    Location
    Louisiana
    Posts
    16
    +1
    1
    Help Please! I have (2) 2012 Seadoo GTI 130’s. Both skis are doing this. We will be out riding along just fine. We decide to kill the engine for a bit. Whenever we go to start them; Nothing. No computer no nothing! I will wiggle the fuse box wire and tap around that area and Bam it starts right up. Again; both skis do this but not every time. Just sometimes. Btw: batteries are 3 yrs old. ???

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,081
    +1
    329
    Probably blown fuse. Pull the battery and unhook the stator connector and there's JUST enough room to wiggle the electrical box out.

  8. #8
    C. June's Avatar
    Join Date
    Apr 2020
    Location
    Louisiana
    Posts
    16
    +1
    1
    Help Please! I have (2) 2012 Seadoo GTI 130’s. Both skis are doing this. We will be out riding along just fine. We decide to kill the engine for a bit. Whenever we go to start them; Nothing. No computer no nothing! I will wiggle the fuse box wire and tap around that area and Bam it starts right up. Again; both skis do this but not every time. Just sometimes. Btw: batteries are 3 yrs old. ???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 09-26-2019, 09:58 PM
  2. Power to dash without key. Battery has constant power.
    By dmarz45 in forum Sea Doo Spark
    Replies: 0
    Last Post: 08-31-2018, 08:10 PM
  3. 1998 XL1200 wonít crank after 2 seasons of storage - no power on new battery
    By ZEW77 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-02-2018, 02:33 PM
  4. 1995 sea doo xp battery...what's a good battery?
    By 95xprider111 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-29-2015, 09:12 AM
  5. ultra 250x 07 good battery but wont crank
    By jcoon92 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 40
    Last Post: 07-01-2012, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •