Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,160
    +1
    122
    Install the plugs.....your problem just might go away

  2. +1 by:


  3. #12

    Join Date
    Apr 2019
    Location
    Jacksonville, FL
    Posts
    27
    I actually bought new plugs for mine thinking maybe they were fouled out or something making it act up but they looked good when I took them out. I swapped them anyway and it didn't fix my issue. I guess I need to find a throttle body.

  4. #13

    Join Date
    Jun 2017
    Location
    Ocean City, MD
    Posts
    488
    +1
    75
    Replaced TB and my ski is fixed. No more codes. I hooked up the candoopro scan tool and checked all the voltages per the manual and they all in spec except the closed tps is was .67 and manual say .3 to .4

    BTW, this tool is excellent. I have 3 skis I can use it on. Good value for me.

    Robert

  5. #14
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,872
    +1
    2,094
    Quote Originally Posted by rcrisafulli View Post
    Replaced TB and my ski is fixed. No more codes.

    I hooked up the candoopro scan tool ...

    BTW, this tool is excellent. I have 3 skis I can use it on. Good value for me.
    ...
    Which codes specifcally identified the throttle body as the problem cause?

  6. #15

    Join Date
    Jun 2017
    Location
    Ocean City, MD
    Posts
    488
    +1
    75
    I had codes 124 TPS, 128 TPS, 132 APS, 134 APS and 151 RPS. I wish I had the scan tool before I changed the TB. After I swapped it the codes went away. My guess is the tb was bad then sets the APS and RPS code because the TPS values are off.

    Robert

  7. #16

    Join Date
    Apr 2019
    Location
    Jacksonville, FL
    Posts
    27
    You replaced it from just swapping it off another ski like you were saying in a previous post or bought one somewhere? Where did you get the throttle body if you bought one? I haven't had any luck trying to located one other than just a new on from the dealer basically which the greenhulk store shows for like $1150. I just can't get over that price for the little tiny throttle body. My upgraded big throttle body on my car was hundreds less than that lol.

  8. #17

    Join Date
    Jun 2017
    Location
    Ocean City, MD
    Posts
    488
    +1
    75
    I have two 2016 FX Cruiser SVHOs. I swapped/stole the TB from the other ski which the motor is out right now. I bought a "new" SVHO TB on the form for 1/3 the cost. It has a different part number on it then my 2016, but that does not mean it is not correct.

    I used the known TB because I want to rule out the TB over the APS triggers. I got my scan tool after the TB was swapped on. I can hook up the other TBs and get there voltages and compare them to the working one.

    You might want to get the voltages values for the TB and APS before buying any parts.

    Robert


  9. #18

    Join Date
    Apr 2019
    Location
    Jacksonville, FL
    Posts
    27
    Quote Originally Posted by rcrisafulli View Post
    I have two 2016 FX Cruiser SVHOs. I swapped/stole the TB from the other ski which the motor is out right now. I bought a "new" SVHO TB on the form for 1/3 the cost. It has a different part number on it then my 2016, but that does not mean it is not correct.

    I used the known TB because I want to rule out the TB over the APS triggers. I got my scan tool after the TB was swapped on. I can hook up the other TBs and get there voltages and compare them to the working one.

    You might want to get the voltages values for the TB and APS before buying any parts.

    Robert
    Bought one off this forum from someone? As in something someone had laying around or something I could also buy at a hefty discount? I have been looking online and when I did a search using the part number it seems like the older SVHO skis like an FZR, etc also used the same throttle body but still haven't had luck finding one under like $950. Saw one used one on ebay for around $550 from Japan but then it says need to find out what they are and pay any import taxes which I have no clue how to go about doing that so didn't want that hassle on top of the unknown of when the thing would even ever make it here coming from Japan.

  10. #19

    Join Date
    Jun 2017
    Location
    Ocean City, MD
    Posts
    488
    +1
    75
    I bought it off this site. Put a wanted ad in the for sale section. You should be able to get a used working one off this site. I see a used one for $700 on ebay right now.

    Robert

  11. #20
    1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,820
    +1
    430
    If you need a throtle body lmk, i got a couple

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ran out of gas now won't start
    By Newtoski in forum Sea Doo Spark
    Replies: 1
    Last Post: 07-16-2018, 05:50 PM
  2. Ran good on the trailer. But bogs in water. Hydrolocked?
    By brando785 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 08-18-2015, 11:22 PM
  3. 2003 gti ran good now no spark!!!!!
    By pwint80 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-16-2014, 06:17 PM
  4. ran out of fuel / now won't start
    By docdoc88 in forum 4-Tec Performance
    Replies: 16
    Last Post: 12-23-2013, 02:01 PM
  5. 2000 Polaris SLH - No Power, Hard to Start, Struggles to REV
    By ThrottleOut in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-03-2011, 07:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •