Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 46
  1. #31
    Brian Quik draw's Avatar
    Join Date
    Apr 2019
    Location
    Jacksonville Florida
    Posts
    38
    +1
    1
    Thanks guys. Head out Timing chain MIA and definitely #2 exhaust valves are bent and #3 seams like they’re sticking. Did see where both of these cylinders did hit a little. I just want to know what to look for and what would have caused the chain to break unexpectedly.


  2. #32
    Brian Quik draw's Avatar
    Join Date
    Apr 2019
    Location
    Jacksonville Florida
    Posts
    38
    +1
    1
    12&3.
    ... 2&3 definitely see where the valves hit and for sure probably bent. #1 looks good.
    Just want to know what to look for to cause the timing chain to break.....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	66 
Size:	126.6 KB 
ID:	459925   Click image for larger version. 

Name:	image.jpg 
Views:	65 
Size:	130.9 KB 
ID:	459926   Click image for larger version. 

Name:	image.jpg 
Views:	66 
Size:	124.0 KB 
ID:	459927  

  3. #33

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    108
    +1
    34
    Hard to tell what may have caused the chain to break. Think some year(s) came with bad chains. Once the motor is out and the PTO cover is pulled look for any extra metal pieces in the screens. Think my chain broke due to damage from a supercharger failure that dropped bearings into the motor. Didnt notice any damage to chain at the time but after reassemby it broke shortly after, bending most of the valves to one degree or another.
    Looks like a couple of your intake valves made contact also. Would replace ALL of them and also the seals.


  4. #34
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,166
    +1
    282
    Make sure you replace it with OEM part# that ends with 042. There were a bad batch of chains that had different part #s.


  5. #35
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,697
    +1
    208
    The timing chain issues were on the 2011’ s From what I remember.

    The 07’s Still had ceramic washers in them, from Factory.
    I would start with the supercharger and check for any damage, or a previous failure that may have helped to take out the chain.


  6. #36
    Brian Quik draw's Avatar
    Join Date
    Apr 2019
    Location
    Jacksonville Florida
    Posts
    38
    +1
    1
    Thanks. I already bought the chain,head gasket and bolts from the stealership. Valves are $84 a piece for the exhaust and $35 for the intake. Just debating on replacing the whole motor and be done with it.

  7. #37
    Brian Quik draw's Avatar
    Join Date
    Apr 2019
    Location
    Jacksonville Florida
    Posts
    38
    +1
    1
    GTRD. How much did you end up spending do you think?
    Last edited by Brian Quik draw; 04-08-2020 at 11:17 AM. Reason: Forgot to mention a certain person.

  8. #38
    Brian Quik draw's Avatar
    Join Date
    Apr 2019
    Location
    Jacksonville Florida
    Posts
    38
    +1
    1
    No damage in the SC. Ski only has 35ish hours. I went ahead and replaced the washers.

  9. #39
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    689
    +1
    32
    Quote Originally Posted by Brian Quik draw View Post
    Just debating on replacing the whole motor and be done with it.
    Can't go wrong and comes with a warranty..

  10. #40

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    108
    +1
    34
    Quote Originally Posted by Brian Quik draw View Post
    Thanks. I already bought the chain,head gasket and bolts from the stealership. Valves are $84 a piece for the exhaust and $35 for the intake. Just debating on replacing the whole motor and be done with it.
    WSM valves are probably half that or less.

Page 4 of 5 FirstFirst ... 2345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo RXT 2005 215 loss of power
    By Bllewellyn in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-07-2019, 05:26 PM
  2. 2005 rxt. 215 intermittent power loss
    By Bllewellyn in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 12-23-2018, 03:45 PM
  3. RXT 215 - Compression - Need Help
    By Rochinha in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-17-2013, 05:54 PM
  4. rxt 215 loss top end speed
    By thomas loh in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2010, 04:05 AM
  5. Help with compression loss!
    By Bknblk in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 06-02-2008, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •