Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 52
  1. #41
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,251
    +1
    712
    Quote Originally Posted by Decompression View Post
    Okay i replaced fuel filter and plugs today got it started again with strong battery waiting to find a pump, Runs but wont idle, will stay running with throttle manipulation. Things are a bit hard to find right now due to the massive amounts of hording going on. what aftermarket fuel pump would you recommend. as the ones for it supposedly in the 500$ range OEM
    Could be something like an air leak causing the idle problem.

    This may help with a fuel pump: http://greenhulk.net/forums/showthread.php?t=187402

  2. #42
    What like a vacuum leak? honestly i was considering IAC

  3. #43
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,893
    +1
    365
    I have had good luck with the walbro gs342, its mega overkill for a stock 12f though. Whatever pump you get, get it with the install kit so it comes with the fuel pickup sock.

    Sean

  4. #44
    Idk if its a walbro or not, but the "fitment" for the GSS 342 is for an 02-07 sti/stx. Found a nicely affordable one at my work due to discount XD. so yes its overkill but it should function for the ski.

  5. #45
    OKAY, replaced fuel pump.... same wants to start but does not. While cranking the alarm will go off as soon as i let everything reset goes back to cranking. Wants to start but does not. Thinking about removing air box and trying to start it with the TB and maybe a camera looking down it. i get the clicking from the IAC resetting after every attempt so i assume that's okay... Go laid off today due to the COVID shutdowns which sucks.

  6. #46


    Got it to idle today, its still a bitch to get it started and it sounds sick. New to ski's anyone take a listen would be awesome point me in a direction. also the IAC (ratcheting gear thing) gets really warm.

  7. #47
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,251
    +1
    712
    Sounds normal to me.

  8. #48
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,893
    +1
    365
    Did you check the fuel pressure after installing the new pump?

    Sean


  9. #49
    not yet, have to re-rent the tool. not something in my arsenal atm. but i at least hear the damnd pump now, and i tried to eliminate fpr by pinching line and wasn't a change

  10. #50
    So i bought a test cause wth, i like tinkering alot ill probably use it. While cranking it Twitches out at about 45, when i stop it usually sits at 40, however sometimes it drains right down to zero. Im guessing on going to need a FPR, any suggestions that wont break my bank?

Page 5 of 6 FirstFirst ... 3456 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Trouble shooting and how to...
    By hansengreg in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 01-14-2019, 07:02 PM
  2. Trouble shooting
    By 01xp in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-15-2016, 07:04 AM
  3. Trouble shooting
    By ethosdrummer in forum Open Discussion
    Replies: 1
    Last Post: 07-27-2015, 05:54 PM
  4. trouble shooting ? help
    By sourpower RXT in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-21-2010, 09:39 PM
  5. Need help trouble shooting
    By hensleybk in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-11-2010, 04:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •