Results 1 to 5 of 5

Thread: Rebuilt FX140

  1. #1

    Join Date
    Apr 2012
    Location
    Sundsvall, Sweden
    Posts
    105
    +1
    1

    Rebuilt FX140

    Hi all.

    Got a FX140 rebuilt. Have started in Before, for about 15-20 minutes, so i could see that everone was ok.
    Now its in the hull. so its time to try it again. with the pump, and new cooling etc.

    What i dident do last time was using any oil amplifier, did just put in fresh oil. What im gonna do now is run i abit longer, to see that Everything is good Before i finish this build.
    So should i use oil amplifier or is it unnecessary at this Point?
    PS. Using oil by the manual.


    Have a great day / Niklas

  2. #2
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    IL
    Posts
    454
    +1
    17
    By oil amplifier are you meaning like a oil additive? I wouldn't think you would need anything special in the oil. It isn't like the old school hydraulic flat tappet cams in a small block chevy that need a zinc additive during cam break in.

    Just make sure you follow the manual for break in service intervals. Be ready for a oil change after 10hrs. Are you using Yamalube or just a oil that meets the manual specifications? If the latter, synthetic or non-synthetic oil?

  3. #3

    Join Date
    Apr 2012
    Location
    Sundsvall, Sweden
    Posts
    105
    +1
    1
    Yes, oil additive. just translated the swedish word for it. My bad.

    Not yamahas oil. But 10w30 Mobil. SYN.
    If i rememberd correcly

  4. #4
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    IL
    Posts
    454
    +1
    17
    Personally, I think I would've used the Yamalube until 10hr service. But that being said, I doubt you will have any issues keeping that in it.


  5. #5

    Join Date
    Apr 2012
    Location
    Sundsvall, Sweden
    Posts
    105
    +1
    1
    Thx for does quick answers Raiderteen. Ill will procced without any additive

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 FX140
    By flryder in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-08-2018, 03:29 PM
  2. FX140 help
    By Rrg16 in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 04-10-2017, 07:11 PM
  3. rebuilt FX140, will not start
    By Niklas in forum Yamaha PWC Performance (4-stroke)
    Replies: 23
    Last Post: 09-16-2015, 08:11 AM
  4. 2-Stroke XLT 1200 rebuilt, newley rebuilt won't turn over by hand!
    By Baypirate in forum Yamaha Projects & Build Threads
    Replies: 6
    Last Post: 08-06-2014, 10:58 AM
  5. 2002 FX140 vs.2004 FX140 HO questions?
    By Handyman in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 10-14-2013, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •