Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48
  1. #41
    Hey there just updating I checked the voltage while cranking with a multi meter and got a solid 11V I also checked the voltage while cranking at the (brown, ground wire) running to the fuel pump and had a solid 11V. I double checked the amps at the same ground and had 6 amps. I don’t think I have any voltage issues just a high current problem I’m going to order a quantum this week hopefully I can only imagine what the pump and tank look like after sitting for so long I’ll keep you all updated as I go, thanks so much for all the help

  2. #42
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,369
    +1
    2,012
    Quote Originally Posted by martincom View Post
    ... K447 has some info, somewhere, on fuel line types and recommendations. ...
    It is in here somewhere

    Quote Originally Posted by K447 View Post
    ...

    You can find wiring diagrams for your year and model and lots more info via my signature links.

    ...

  3. #43
    Hey guys Iím not sure if my last post made it or not but Iím gonna try again here... I checked my voltage while cranking with a multi meter and had a solid 11V I also checked the voltage at the brown wire on the fuel pump while cranking and had a solid 11V I double checked the amps on the same brown wire and had 6 amps. Hoping to order a quantum pump this week. Iíd say I have a current/ pressure issue. Iíll keep you updated when I get the tank apart thanks for all the help I appreciate it! Iíve been ordering clamps and fuel line as well! Martincom I really appreciate you offering the wireing harness but I think mine is salvageable once I realized what they were trying to do it was easily fixed! Wish me luck Iíll keep yea posted

  4. #44
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,957
    +1
    234
    Quote Originally Posted by Ryan-virage View Post
    I was also wondering what everyone recommends for replacement fuel line I have that horrid grey line and would like to replace it while diagnosing.
    Marine rated hose, B1 minimum (that's what it came from the factory with), A1-15 is the best but depending on brand I've found that it is too bulky and runs the risk of putting undue force on the fuel injector fittings, running the risk of breakage.

    THIS fuel line (Trident Marine B1 Fuel Hose) I find very easy to work with, but its a little on the flimsy side but B1 rated nevertheless.

  5. #45
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,090
    +1
    114
    I've been utilizing the MPI brand, part number: 315-0146. I did a quick search and found an ebay seller it by the foot, albeit at a pretty steep price.

    Here is where I've been sourcing it.

  6. #46
    So I also wanted to mention I talked to the old man and he had the EMM checked by DFI... haven’t heard great things about them...cost him 5-600$ Canadian after shipping he thought.. so if I do instal the new pump and everything else and still have a no start who else can I get to check the EMM and roughly what would that cost Canadian?

  7. #47
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,957
    +1
    234
    Quote Originally Posted by Ryan-virage View Post
    so if I do instal the new pump and everything else and still have a no start who else can I get to check the EMM
    Lakeside Tech would be my first choice

  8. #48
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,675
    +1
    2,075
    Quote Originally Posted by HiPeRcO View Post
    Lakeside Tech would be my first choice
    Lakeside is my first choice now , DFI was just taking too long to return EMM's since 2018 it's taken like forever to even to get them to return a phone call, as good of a relationship as I had with them for close to ten years, sometimes you just toss out the ski with the tankwater


Page 5 of 5 FirstFirst ... 345

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Virage 800 Problems
    By Luichi787 in forum Polaris PWC Performance
    Replies: 8
    Last Post: 07-10-2013, 08:50 AM
  2. 96 XP 800 X4 problems (we need experts to help)
    By wackyman71 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-22-2012, 09:48 PM
  3. GP 800 Problems Please Help
    By myersmotorsports in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 02-22-2011, 03:08 PM
  4. still having problems with 95 800 xp
    By TonyT in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-21-2010, 07:14 PM
  5. having problems keeping my 95 800 xp running
    By TonyT in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-16-2010, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •