Results 1 to 9 of 9
  1. #1

    Ultra 250X wonít rev past 6200rpm 80kph

    Any ideas why my ski revs Fine out of the water but wonít go over 80kph and wonít rev past 6200rpm on the water

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,000
    +1
    679
    Welcome aboard, jxerri!

    Have you inspected/rebuilt the jet pump and checked for crankshaft movement? The jet pumps on that model are known for failing and pushing forward on the crankshaft, destroying the engine.

  3. #3
    I’ll check it out
    the ski has only done 10 hours since new
    I had to clean the injectors out when I got it as they where all gummed up from sitting around for 7 years

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,000
    +1
    679
    Did you check the fuel pump? If it sat that long with fuel in it, the inlet screen is probably plugged. The whole pump could be trashed.

  5. #5
    I get 150ml every time I do the 3sec fuel test

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,000
    +1
    679
    I picked up an STX-15F that had sat for 8 years. This is what the fuel pump looked like:



    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	STX-12F Fuel Pump 1.jpg 
Views:	43 
Size:	189.3 KB 
ID:	458184   Click image for larger version. 

Name:	STX-12F Fuel Pump 2.jpg 
Views:	43 
Size:	326.8 KB 
ID:	458185  

  7. #7
    Wow that’s stuffed
    I pulled the pump out and apart but look like new in there
    could it be faulty plugs I did change them
    but it seams to run fine but doesn’t pull your arms off like it did when I first got it going and won’t rev past6300

  8. #8
    Quote Originally Posted by jxerri View Post
    Wow thatís stuffed
    I pulled the pump out and apart but look like new in there
    could it be faulty plugs I did change them
    but it seams to run fine but doesnít pull your arms off like it did when I first got it going and wonít rev past6300


    all sorted turns out the new plugs i put in one of them had an issue


  9. #9
    any idea why it might be fouling plugs its done it to 3 now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 ultra 300x wonít rev past 5800rpm
    By Ausjet01 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 01-03-2020, 03:18 AM
  2. Ultra 150 wonít rev past 4000
    By Rxpx260rider in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-04-2019, 05:05 PM
  3. MSX150 won't rev past 4400
    By matfan in forum Polaris PWC Performance
    Replies: 2
    Last Post: 12-01-2013, 06:46 PM
  4. msx150 won`t rev past 3400rpm
    By hotx19 in forum MSX/Matrix
    Replies: 30
    Last Post: 09-04-2011, 09:35 PM
  5. 96 sltx won't rev past 5600rpm
    By raiderman444 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-09-2009, 11:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •