Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45
  1. #1
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4

    Wobble of Carbon seal / Floating ring - see video. is this normal?

    I have a bit of a wobble of the floating ring/carbon seal on my 2017 RXPX (100hrs, salt water use)

    see slow motion video of it at idle speed

    https://drive.google.com/open?id=1L0...uBpuih_O0LPv98



    Ive pulled the drive shaft and carbon seal. there was a little bit of corrosion under the floating ring, but it isnt bad. the orings inside the floating ring look good, the c-clip looks pretty good, and the parts all fit together tight.

    see photos of the parts
    https://drive.google.com/open?id=1vI...K0zhqqt1PLn3Qb

    i checked engine alignment (it is perfect), the drive shaft is straight, and the carbon seal and bellows are in good shape.

    when i assemble the floating ring and c-clip on drive shaft out of the ski, and press the floating ring up against the c-clip, and then rotate the drive shaft, i can see that the floating ring isnt on square/perpendicular to the driveshaft
    i think it some how has to do with the fact that the c-clip is only half a circle, and only supporting half the floating ring, thus creating a poor fit.

    thoughts?

    thanks
    -Phil
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20200202_135257.jpg 
Views:	68 
Size:	42.8 KB 
ID:	457844  
    Last edited by Makesumwake; 02-02-2020 at 03:14 PM. Reason: photos


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,687
    +1
    195
    My guess would be the c-clip and the grove are worn or the inside of the hat is worn where the c-clip rides
    Sadly that would mean a new drive shaft, c clip and hat

  3. #3

    Join Date
    Sep 2015
    Location
    OC MD
    Posts
    139
    +1
    2
    Quote Originally Posted by makesumwake View Post
    i have a bit of a wobble of the floating ring/carbon seal on my 2017 rxpx (100hrs, salt water use)

    see slow motion video of it at idle speed

    https://drive.google.com/open?id=1l0...ubpuih_o0lpv98



    ive pulled the drive shaft and carbon seal. There was a little bit of corrosion under the floating ring, but it isnt bad. The orings inside the floating ring look good, the c-clip looks pretty good, and the parts all fit together tight.

    See photos of the parts
    https://drive.google.com/open?id=1vi...k0zhqqt1pln3qb

    i checked engine alignment (it is perfect), the drive shaft is straight, and the carbon seal and bellows are in good shape.

    When i assemble the floating ring and c-clip on drive shaft out of the ski, and press the floating ring up against the c-clip, and then rotate the drive shaft, i can see that the floating ring isnt on square/perpendicular to the driveshaft
    i think it some how has to do with the fact that the c-clip is only half a circle, and only supporting half the floating ring, thus creating a poor fit.

    Thoughts?

    Thanks
    -phil
    is it leaking ? What is the problem?

  4. #4
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    Quote Originally Posted by rtarford View Post
    is it leaking ? What is the problem?

    i have some cavitation and water getting into the hull
    i havnt confirmed yet that it is from a leaking bellows, but this wobble seems suspect.

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,106
    +1
    798
    Great job finding the source of your cavitation!

    Clearly, you need to replace all drive line components as yours is worn unevenly.

    drive shaft
    c clip
    carbon ring
    floating ring
    bellows
    PTO seal

    check splines on impeller for uneven wear

    recheck alignment with new parts

    Great video.

  6. +1 by:


  7. #6

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,065
    +1
    170
    Quote Originally Posted by Makesumwake View Post
    i have some cavitation and water getting into the hull
    i havnt confirmed yet that it is from a leaking bellows, but this wobble seems suspect.
    I wouldn't blame the wobble for a leak-my '17 RXT carbon seal wobbles and I don't have a water leak. After having about 5 rings replaced on mine I have seen several failure modes. My driveshaft was replaced for wear of the c-clip groove like that seen on yours. You can see that the c-clip is also wearing. One of the failure modes I've experienced is the clip wearing completely through and coming out. While you have the driveline apart, I would check the alignment of the thru hull fitting also.

    Good job of presenting the situation with the video and pictures!

  8. #7
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    Quote Originally Posted by pro1200 View Post
    I wouldn't blame the wobble for a leak-my '17 RXT carbon seal wobbles and I don't have a water leak. After having about 5 rings replaced on mine I have seen several failure modes. My driveshaft was replaced for wear of the c-clip groove like that seen on yours. You can see that the c-clip is also wearing. One of the failure modes I've experienced is the clip wearing completely through and coming out. While you have the driveline apart, I would check the alignment of the thru hull fitting also.

    Good job of presenting the situation with the video and pictures!
    wow, you got bad luck with the rings. i try to keep everything lubricated inside the ski to prevent these issues. in this case i missed the area under the floating ring. im going to start lubricating the floating ring and drive shaft with synthetic grease (o-ring safe) to prevent the corrosion

    im not sure how to check alignment of thru hull fitting but i will start googling it now. but the carbon seal seems aligned on the floating ring....at least from looking at it and feeling around it with my hand.

  9. #8

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,065
    +1
    170
    https://www.4-tecperformance.com/ind...oducts_id=2483
    My understanding is that this adapter is mounted in the bellow during the alignment process. The alignment shaft is then inserted and any deflection is noted. If there is a significant amount, the thru hull fitting may not be square with the pump shoe. What I find odd is that I can't find this part of the alignment procedure in the factory service manual.

  10. #9

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    91
    +1
    32
    Quote Originally Posted by pro1200 View Post
    https://www.4-tecperformance.com/ind...oducts_id=2483
    My understanding is that this adapter is mounted in the bellow during the alignment process. The alignment shaft is then inserted and any deflection is noted. If there is a significant amount, the thru hull fitting may not be square with the pump shoe. What I find odd is that I can't find this part of the alignment procedure in the factory service manual.
    Adapter goes in the thru hull fitting for alignment not the bellow. Probably not in the service manual cause they dont bother to use it. Cause of factory misalignments. The newer bigger hats were put in to cover up for the mess but put more pressure on the outer edges causing wobble and spitting out c-clips. Align the best you can. I cut a piece out of another clip to make almost a full circle. No wobbles for over a year now.

  11. +1 by:


  12. #10
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    Quote Originally Posted by GTRD View Post
    ....I cut a piece out of another clip to make almost a full circle. No wobbles for over a year now.

    great idea. it think that alone will fix my problem. ill try it this week and report back

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 08-03-2019, 08:32 AM
  2. Question about floating ring and carbon seal
    By JoeTe in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-13-2017, 10:43 AM
  3. O-ring for the floating ring for the carbon seal
    By Stein3247 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-18-2015, 09:19 AM
  4. Normal carbon seal wear?
    By Allen8801 in forum 4-Tec Performance
    Replies: 22
    Last Post: 06-17-2014, 05:58 PM
  5. Floating & Carbon Ring dressing
    By lafjax in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 12-05-2007, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •