Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45
  1. #21
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    66
    +1
    5
    https://drive.google.com/file/d/1UTQ...w?usp=drivesdk

    Could it be causing vibration between 8000-8500 RPM?


  2. #22
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    Quote Originally Posted by NitroFish300 View Post
    https://drive.google.com/file/d/1UTQ...w?usp=drivesdk

    Could it be causing vibration between 8000-8500 RPM?
    thats def wobbling a lot! similar to mine. not sure i noticed any vibration though. make sure your driveshaft is not bent, and is aligned. check the impeller and pump bearings also

  3. #23
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    66
    +1
    5
    Dang and I just had it tore down to replace the carbon seal didn’t look over the drive shaft though

  4. #24
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    66
    +1
    5
    must of been cavitation not vibration because my impeller has some pitting on the tips and it wasn’t like that the other day. And the C-clip has two flat spots with the drive shaft

  5. #25
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    Quote Originally Posted by NitroFish300 View Post
    must of been cavitation not vibration because my impeller has some pitting on the tips and it wasn’t like that the other day. And the C-clip has two flat spots with the drive shaft
    ok, that makes sense

  6. #26
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    just saved $450 by switching to 2 C-clips. Problem is fixed

    video here
    https://drive.google.com/open?id=1GU...A7ogM3jAQkB---

    I did what GTRD said. i cut a 2nd C-clip to fill the gap left by the main C-clip. now the floating ring doesn't wobble!

  7. #27
    Wow, massive difference between your first video and the last!!

  8. #28

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,065
    +1
    170
    Quote Originally Posted by Makesumwake View Post
    just saved $450 by switching to 2 C-clips. Problem is fixed
    I did what GTRD said. i cut a 2nd C-clip to fill the gap left by the main C-clip. now the floating ring doesn't wobble!
    Thank you GTRD and Makesum wake! This solution makes sense to me. Each time I have had a carbon ring replaced on my '17 RXT there is no wobble until about 20 hours and it starts again. I believe the BRP engineers are designing on the fly and the larger diameter sealing ring created another problem. Like GTRD implied, since they accepted that wobble couldn't be eliminated in an economical way they just made the ring larger so the seal wouldn't leak while it is wobbling.

  9. #29
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    81
    +1
    4
    its such an easy/cheap solution also!!! ive packed the area under and around the floating ring with synthetic grease (wont harm o-rings)
    this should keep the corrosion out of it, and i expect to not have any more issues for a long time with this fix.

  10. #30

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,065
    +1
    170
    Let us know if you are still seeing water in the bilge. I doubt the wobble and wear on the carbon ring was significant enough to cause a leak but it would be easy to check. With the ski in flyboard mode and running with the seat off you can just observe if water is coming in at the carbon ring/sealing ring interface.

Page 3 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 08-03-2019, 08:32 AM
  2. Question about floating ring and carbon seal
    By JoeTe in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-13-2017, 10:43 AM
  3. O-ring for the floating ring for the carbon seal
    By Stein3247 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-18-2015, 09:19 AM
  4. Normal carbon seal wear?
    By Allen8801 in forum 4-Tec Performance
    Replies: 22
    Last Post: 06-17-2014, 05:58 PM
  5. Floating & Carbon Ring dressing
    By lafjax in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 12-05-2007, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •