Results 1 to 4 of 4
  1. #1

    Join Date
    Jan 2020
    Location
    Haleiwa
    Posts
    2

    2017 FXHO Starting issue

    Hey Guys,
    New to Green hulk and wanted to see if anyone had advice.

    I have a 2017 FXHO with 24 HRs on it suddenly would start.never had issues starting or running.Then suddely, Only thing that happens when I press the green start button is the green light next to "unlock" flashes on and then turns off. I changed the battery in the remote, charger the battery in the ski, changed the security module and nothing changes.

    Any advice?

  2. #2
    Have you tested the battery after charging it ?? 24 hours use in 3 years suggests you haven't used it much and it could be effed.

    If the battery is good remove the terminals and sand the lead top surface and the cable terminals then wipe clean with alcohol and bolt them back together and try again.

    If the green light only comes on goes away and the display is not showing anything it suggest a battery voltage supply issue.

  3. #3

    Join Date
    Jan 2020
    Location
    Haleiwa
    Posts
    2
    Thank you Diegosan! You were correct. Ended up the Battery was faulty. I did charge the battery when the problem started but assumed because the trickle charger said it was good to go that the battery still function properly.
    I appreciate you taking the time to respond to my question.

    Aloha!

  4. #4
    No problem, modern chargers are clever but common sense is cleverer, glad you got it sorted.
    Quote Originally Posted by 808LG View Post
    Thank you Diegosan! You were correct. Ended up the Battery was faulty. I did charge the battery when the problem started but assumed because the trickle charger said it was good to go that the battery still function properly.
    I appreciate you taking the time to respond to my question.

    Aloha!


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2017 gp1800 engine alarm when starting
    By aerostern in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-29-2018, 09:04 PM
  2. FXHO 2014 (Used, 164h) vs VX Deluxe 2017 (New, 0h)
    By lagoondweller in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 10-06-2017, 05:41 AM
  3. 2017 FXHO Solas impellar?
    By eman2289 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 07-05-2017, 11:03 AM
  4. 05 FXHO not starting
    By cigarlust in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 06-19-2012, 08:23 PM
  5. 09 FXHO 1.8 starting question
    By baba booey in forum Yamaha Open Discussion
    Replies: 23
    Last Post: 07-05-2010, 01:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •