Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    isa alnoaimi's Avatar
    Join Date
    Nov 2012
    Location
    bahrain
    Posts
    750
    +1
    22

    RIVA RACING 340LP fuel pump issue

    hi everyone

    i installed the riva 340LP fuel pump in my ski , the issue is that my ski is dumping too much fuel at ideal !!!!

    i tried various maps from map tuner server , but with no luck .

    i lowered the fuel by from 50 psi till 20 psi , so that the ski ideals correctly and the engine won’t shit down .

    today i removed the 340LP pump and installed the OEM pump
    and ski is idealing correctly !!!

    did anyone here had this issue with riva 340LP pump ?

  2. #2
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,118
    +1
    117
    If it's a brand new pump from Riva, call Brian Rosencrantz and have a conversation with him.
    He can really help you.

    Dave


  3. #3
    You're going to need a custom fuel map. The riva tunes in the libary are not compensating for the big pump. I don't see any aftermarket fuel pump in any of their tunes online.

  4. #4
    isa alnoaimi's Avatar
    Join Date
    Nov 2012
    Location
    bahrain
    Posts
    750
    +1
    22
    Quote Originally Posted by bryan.daniel1990@gmail.co View Post
    You're going to need a custom fuel map. The riva tunes in the libary are not compensating for the big pump. I don't see any aftermarket fuel pump in any of their tunes online.
    thanks

    i just emailed brian at riva racing


  5. #5
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,752
    +1
    416
    What are your afrs ? Or “idles correctly” is your afrs ?

  6. #6
    isa alnoaimi's Avatar
    Join Date
    Nov 2012
    Location
    bahrain
    Posts
    750
    +1
    22
    i didn’t bother my self to hook up the O2 sensor

    spark plug is Pitch black
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	ADBED4A8-2AE3-4B71-BEFE-CA9DF5619B42.jpg 
Views:	30 
Size:	31.3 KB 
ID:	457663  

  7. #7
    isa alnoaimi's Avatar
    Join Date
    Nov 2012
    Location
    bahrain
    Posts
    750
    +1
    22
    is it necessary to install the block off when installing the riva 340LP fuel pump when using riva FPR ?

    when i had this issue the block off was installed , but i just noticed that in riva instructions they are saying its not necessary to install the block off when using the big pump .

    maybe that was my problem ? causing my ski to be very rich at ideal ?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	9D15EC5F-CB7A-4C12-BE65-7C40946E0939.jpg 
Views:	103 
Size:	51.6 KB 
ID:	457795  

  8. #8
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    8,699
    +1
    578
    I run rrfpr with block off and fuel pump kit. Static at 58psi. No ssues with rich conditions on my 2020 ski

  9. #9
    isa alnoaimi's Avatar
    Join Date
    Nov 2012
    Location
    bahrain
    Posts
    750
    +1
    22
    if your set up is like mine , so why the hell is this fuel pump is dumping to much fuel at ideal !!!

  10. #10
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,752
    +1
    416
    Quote Originally Posted by isa alnoaimi View Post
    if your set up is like mine , so why the hell is this fuel pump is dumping to much fuel at ideal !!!
    Probably your flash or injectors. Clean your injectors

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4 tech fuel pump issue.
    By Tintman20 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-14-2019, 12:18 PM
  2. Replies: 7
    Last Post: 01-25-2017, 10:18 PM
  3. Replies: 4
    Last Post: 10-16-2016, 12:15 PM
  4. WTB WTB: 07+ Racing ECU (Riva,RR,Reflash) OL Rideplate (prefer Riva) Fuel Tuner
    By boostaholic in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 03-26-2011, 01:49 AM
  5. Walbro fuel pump issue!!!
    By FreakRXP1200 in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-25-2010, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •