Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33
  1. #21
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,897
    +1
    2,095
    Quote Originally Posted by TurboX View Post
    ... My local performance shop states its highly unlikely that its the clutch, the ski would never rev to full power and cut back. If clutch was failing ski would likely never rev to full power ...
    That would be almost exactly the symptoms when my GP1800 clutch began to fail.

    As long as the jet pump was fully hooked in the water up the engine could produce [nearly*] full boost and power. As soon as the jet pump bounced out of the water over some waves the clutch would slip and maximum RPM would drop. Power would remain limited until throttle lever was suddenly and fully released, then could re-engage throttle and have full power again. Until the next wave unhooked the jet pump.

    Replaced the clutch, problem went away.

    * Correction.
    As I continued to ride the clutch slip became more consistent and would more consistently lose boost above about 3/4 throttle even without the jet pump unloading.
    Last edited by K447; 04-05-2020 at 10:57 PM. Reason: Clutch would slip if throttle was squeezed more than about 3/4


  2. #22
    Thanks for all the comment guys, today I changed oil, filter and plugs and problem is still there. The water was glass and the ski is not unloading pump, it goes WOT and then just goes from 8000+ RPM to just 6000RPM.

    It got dark on me but later this week I will troubleshoot some more, Im really disappointed if the clutch did let go because I do not let pump load and unload and am not a person to be racing WOT all the time. In a normal day where I ride 4 hours, I doubt Im WOT for 10 minutes total. Most my cruising is done at 6000-7000 rpm if water if flat with little chop.

    Next question, Deans Team Clutch or Stock ?

    Thanks

  3. #23
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,897
    +1
    2,095
    Quote Originally Posted by TurboX View Post
    ... In a normal day where I ride 4 hours, I doubt I'm WOT for 10 minutes total. Most my cruising is done at 6000-7000 rpm if water if flat with little chop.

    Next question, Deans Team Clutch or Stock ?
    ...
    If indeed your original clutch has begun to slip, your use description still seems like a match for the factory clutch. Despite the apparent ‘early’ failure, I do not see a reason for the Yamaha replacement clutch to provide less than the typical service life.

    I forget the exact price of the Dean’s clutch but it is a multiple of the genuine Yamaha clutch, correct?

  4. +1 by:


  5. #24
    Not to beat a dead horse, just want information out there for future people with problems.

    I believe K447 is correct and clutch is shot.

    I went back out this afternoon but took seat off to look for possible boost leak or air filter collapsing. The Sky revved past 8000 and then backed down to 6000rpm, I would let engine come down to a idle and as it dropped I heard a clunk. The best way I can describe the clunk is like what happens when you put a boat from neutral into drive or reverse. When I removed the intake tube going to Supercharger, I found oil inside. The Supercharger wheel only spins in 1 direction and won't spin opposite.


    Thanks

  6. #25
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,897
    +1
    2,095
    Quote Originally Posted by TurboX View Post
    ... When I removed the intake tube going to Supercharger, I found oil inside.

    The Supercharger wheel only spins in 1 direction and won't spin opposite.
    ....
    How much oil was inside the air intake tube?

    Stock airbox, correct?
    The crankcase vent hose routes oily fumes into the supercharger intake tube.

    When I removed my GP1800 intake tube (about 200 running hours since I last looked in there) there was a ‘dribble’ of oil puddled just in front of the supercharger inlet. Maybe a teaspoon of oil, probably less. Which I considered to not be a worry.


    My ‘worn& slipping’ SVHO clutch, after removal from the engine, still looks and feels essentially like new. The clutch engages in one direction, and spins easily in the other when operated by hand. No funny noises, no metal particles.



    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	6DAA4CEB-2D1B-45A7-99C7-06346EC21944.jpg 
Views:	155 
Size:	84.5 KB 
ID:	459982   Click image for larger version. 

Name:	1033EE05-1CD5-4B92-A72F-492CE6BD8C69.jpg 
Views:	155 
Size:	106.8 KB 
ID:	459983  

  7. #26
    I have the Riva intake with K&N Filter, dont even have the vent tube connected. I would call it more than a film, Im trying to post photos but seem to have issues.

  8. #27
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	358CF84F-F017-4168-9AE5-255CB5F3BBFF.jpeg 
Views:	156 
Size:	122.4 KB 
ID:	459986  

  9. #28
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	C5ACFE81-7D38-4B8E-AB83-0BB494F1E5B6.jpeg 
Views:	159 
Size:	103.0 KB 
ID:	459987  

  10. #29
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,897
    +1
    2,095
    Quote Originally Posted by TurboX View Post
    Looks about the same amount of oil I had.

  11. #30
    Yeah but I dont have a crankcase vent tube plumbed into intake, the intake is capped and crankcase vent tube has a K&N Filter.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of Power, Loss of oil, loss of coolant
    By Keatooon9988 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-02-2019, 06:12 AM
  2. 2017 GP1800 Thread
    By not2fast in forum Yamaha PWC Performance (4-stroke)
    Replies: 25
    Last Post: 08-31-2016, 12:02 PM
  3. 2001 ultra 150 power loss at times gains fuul power hitting chop
    By loverichardamy12 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-10-2016, 05:58 PM
  4. Intermittent Loss of Power above 6000 RPM. Power Valves? - GP800R
    By mfabel in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-29-2015, 05:34 PM
  5. 2007 RXP oil loss/power loss
    By Mcr1994 in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-30-2013, 10:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •